Twilio API won't send MediaURL, MMS Messaging

Hi there, I’m trying to send MMS messages with Twilio API. My API works with SMS messages no problem. I have an MMS enabled number as well.

However, when I initialize the call, everything works but nothing is coming back recognizing the MediaURL and the texts don’t include a image.

What am I doing wrong here?

I had to use the body area to make it work. There is something weird about how bubble sends query parameters when sent using the regular fields that doesn’t work for Twilio. Probably adds unnecessary brackets or quotations or something.

1 Like

Thanks for getting back to me here!

Curious though, what is different between what you did and what I did? Other than the callback URL param. I think I may be missing something else here.

Hello, I was able to get this to work recently. See screenshots below. My texts were coming back with no image, then I realized it was because my dynamic image URLs weren’t complete - I was pulling images from bubble db but wasn’t adding https: in front. Hope this helps!


Hi ther! First thank you for chimming in here!

However, I tried what you recommended and still to no avail.

I even stored the url in a text field to double check it had https://, which it did!

When you in reinitialize the call, does your phone receive a text with an image?

Yep, when I reinitialize I do receive a text with an image. Also worth noting – in the image above where I point to the MediaURL and https:… from there I’m referencing against an actual image stored in my DB (vs a text field with a URL stored)… so it is like https:[database-image]. I saw in your db screenshot you had the image + media URL link. If you haven’t done this already, try updating to do this.

First of all, thank you for coming back! This has been plaguing me for a while and I can’t figure it out!

I will try what you said!

With that being said, when I reinitialize the call, I’m still not getting an image through the text. Which makes me think there is something wrong with the API set up. I copied the exact way you set it up, and when I initialize the call, still no image. The image is public so no restrictions there.

Are you seeing any errors when you try to initialize? Maybe also try instead of “From” having the Twilio number, have it point to a messaging service which you create in Twilio portal (and the number will be linked to that messaging service in Sender Pool).

No errors in so far :sob:

Is it because I’m pending approval on A2P? But I would think if I can send SMS texts, then I could send images as well. If the pending A2P was the issue, wouldn’t I not be able to send SMS texts?

what happens when you click initialize?

When I initialize it goes through and I receive the text on my phone. Just no image

It’s not A2P, didn’t register yet myself. Check the size of your images. Max size is 5MB. Try making file size very small and giving it a shot.

Image sizes are all under 5MB - I’ve tried to even do it in postman but no luck still.

UPDATE: Still no solution, if anyone has any ideas I am very open to them. For now, I will have to send the url in the body of the SMS and let the users open it via their web portal. It’ll work for now but I need to get this fixed at some point

Sorry couldn’t help! Last thing top of mind, make sure Twilio is fully setup for MMS. E.g… number must be able to support MMS, etc.

Unfortunately…it is. But I really appreciate you taking the time - thank you!

Your media parameter should be “MediaUrl” not “MediaURL” that may be your issue.

You’re the man! Thank you sir!