Add dynamic data to API problem

Hi guys! I am struggling with editing dynamic data within a API. I want that the “stripe.com” changes when a customer fills in a other domain. But when I use the params to give the users the option to add data, the values that are returned are not the ones I need (see difference in screenshots). Can someone help me fix this? Thanks!




I’d guess it’s because you’re not using a valid URL (i.e. ‘1’ is not a valid URL)

Thank you for your response Adam. I am sorry, I think I didn’t get the question out right, I want that the url changes when my users are using an input, for example that my users fill in the url "apple.com

Yes, I understand the question…

But in your screenshot you’re not using a valid URL, which is why you’re not getting any data when you initialize the call…

Hi Adam, thanks for the reply again. You mean It is not valid because of the ? When I manually change the url it works, but I want my users to fill in an input wich will change the URL wich has to be searched.

No, I mean it’s not valid because of the ‘1’ (that’s not a url)

Aha! Thank you! But how can I change that value to dynamic data wich my users can fill in?

Just use [] to make the value in the URL dynamic…

e.g. https://api.hunter.io/v2/domain-search?domain=[url]&api_key=API_KEY

Then you can enter a URL as the key value (it must be a valid URL)

Thanks for the fast reaction, again. I still don’t really understand what have to be done. How can I give this api the task to gather the information from an input that my customers fill in?

As you’ve got the API call set as a Data call, you’ll need to use it as the data-source for whatever it is you want to use it for on your app page.

When you set it as the data source, you’ll see all the parameters you’ve set up (as long as they’re not set to ‘private’), so you can populate the values however you like (i.e. from an input).

note: in your screenshot above you’ve got the parameter set to ‘private’ so you won’t be able to set it dynamically… so you’ll need to uncheck the ‘private’ checkbox.