Forum Academy Marketplace Showcase Pricing Features

Address (geographic address) csv data upload not working

Here is my issue:
I am trying to import csv file containing several data types including geographic address. Everything works fine, I even get the error message for address not recognized as an address to fix, but at the end no data is showing in the field address.

Thanks for your suggestions


Try to import it as text and see if it shows up. Sometimes the addresses don’t import well. So you have a Google API key set up yet?

Thanks Troy
Do you mean to change the data type to Text and then back to geographic places once uploaded?

Yes the API set up is done and when adding an address manually in the database, it works perfectly.

Yeah just try that to see if the field imports, or if something else is the issue.

Unfortunately does not work… I am still searching!

Show your data. Take a snip of the headers and a few lines.

That’s very odd

Try adjusting some of the age range data. I’m guessing that field is messing up the import. Try it by splitting up the CSV and only trying to import the addresses. See if it works.

Still not working… Is there detailed documentation I can read through about data upload?

Not really. There must be something wrong with your CSV. Are you sure you are using the proper delimiter?

You will just need to identify why your CSV isn’t working.

So I’ve tried a lot of different things, it seems that it is really the upload of geographic address data types that is an issue. I am exploring issues with the google api quotas.

What you could do is use @troy.roberge’s suggestion of importing the .CSV but with your Address column mapping to a temporary field in your database like, “Address (Text)” and set the type to text.

Then if it imports (which it sounds like you’re even having trouble with that, which is odd), you can create a field in your database like, “Address (Geographic),” set up a backend API workflow to then bulk update the old “Address (Text)” to the new “Address (Geographic).”

I have the same issue. Used to work fine before though. Glad to have your feedback if you find a solution!

I’m having the same issue! I bet it’s a bug.

It’s an issue cause its trying to do address validation on every single address imported, better to just get the data in a text field and mirror it over and double check its work, it could still lookup and match the wrong address if your text address was slightly incorrect.

1 Like