API connector not sending JSON body in POST request

Been developing on bubble.io for a while and never had trouble with the connector till now.

I know my call is set up to a tee from the documentation and it runs perfect on postman.

For some reason this user_id field is not going through and I have no idea why, very stressed with this and thankful for any input!

I looked at similar posts and tried url encoded content type as well as use the shared headers… still nothing

1 Like

did you tried to add the headers directly to your calls (instead of shared header)?

Link to documentation?

1 Like

Or you can share your settings in Postman (headers, parameters, body…)

Yes I did headers both ways

Try to start from a new API and Call and set headers directly in API Call in lowercase
If this doesn’t work, try to send the request to a requestbin.com and do the same in postman and compare both calls.

@Jici That URL looks broken perhaps you meant https://pipedream.com/requestbin

The url was parsed automatically. :stuck_out_tongue: However .com instead of the old .org work

1 Like

I’ve had this issue as well with some POST requests to other APIs, and this was the solution for me. Try using this as JSON:


Is this still working for you? I am facing the same problem and nothing is working.