App editor running ridiculously slow

An editor on my app is running ridiculously slow for 3 days now. Especially if I start reorganizing or creating workflows. While my other is completely without a problem.

Any tips on how to make this go away. I have deleted all the unnecessary plugins. Narrowed down the app to as little pages as possible. However it only seems to be getting worse.

Already filled a bug report few days back but haven’t heard back from anyone.

I think that this is a JS error or slow loading script.

I too face the same problem all the time… I need to shut down all open tabs and windows and re-open them again.

There is also an ongoing Session issue where the system logs me out all of the sudden out of Bubble. It does this 3-4 times a day as well (if I’m working 8 hours a day developing).

@JustinC- Thanks, shutting down all tabs and reopening them worked.

It only fixed it for about 20 minutes, now shutting down the tabs & computer doesn’t solve it anymore. Any other suggestions?

Is it showing ‘checking for errors’?

Yes it is ‘checking for errors’

Issue checker is supposed to be disabled on my app (unless a new background process is run for the issue checker improvement).
For 2 days, when loading a new page, it takes a while (> 30 sec usually) before workflows can be seen and edited.
However design elements are quickly editable as it was before.

We’re deploying a change that should help this now… should be live in the next 30 minutes - > couple hours. Sorry about the annoyance here.

Change is live. If you’re still seeing problems let us know…

Nope, the app is still not accessible for me, its now been two plus full days…the app is “checking for issues” continuously.
Haven’t been able to use the app all weekend.

Can you file a bug report so that we have a link to work with?

It seems workflows are accessible a bit quicker than yesterday but not much quicker

It worked for a bit however after about 30 minutes it started “Checking for issues” again.

btw- this only happens on one of my projects. The other one is completely unaffected.

I’m having the same issue since yesterday! :frowning:

if you make a copy of the application does that work without issues?

I haven’t tried making a copy yet, however, I submitted a case on 7/9…thanks.

If you add “&issues_off=true” to the end of the editor url, that will disable the issue checker. We’re in the process of revamping the issue checker this week to get rid of the performance issues, but in the interim, disabling it will let you work without it getting in the way.


Ok, thank you, will run with that for now…that does seem to help, it’s not hanging up when I make changes to a page so that’s good.

I have noticed the following in the past, and maybe this isn’t the case anymore, as usually quitting my browser and re-opening it clears things up, or restarting my Mac. But, if you are in a place you can do it: deploy from dev to live. I have seen this clear up hangs and sluggishness on issue checking and editor performance. bottom line: the editor runs notably faster afterwards–sometimes, typically when having done a lot of dev work without going live for quite a while.

Not sure how this fits in with any recent issue checking improvements, but deploying to live seems to re-set some things on the dev side, giving the feeling of a clean slate on the editor. Just a hunch on what is the reason, but has helped in the past.

Also, I normally keep my Apple activity monitor running and if the memory for my browser running bubble editor hits 4 or 5 gig it’s time to quit and re-open the browser. And as Josh says running with issue checking disabled can help a lot too i.e “&issues_off=true” on your url

Issue is solved for me. Workflows are quickly available since yesterday.