Apple Rejected app due to ipv6 loading issue

Hi Bubblers,

I am hoping someone has some help with this, couldn’t find anything on the forum. Apple has rejected an app submission with the following reason:

We discovered one or more bugs in your app when reviewed on iPad running iOS 10.3.2 on Wi-Fi connected to an IPv6 network.

It seems that the app is not loaded past the splash screen when connected via ipv6 network. I have tested this on my home network without issues however not sure what the issue could be that they are experiencing.

The bubble app is using SSL on a custom domain.



After much research and trying to find an issue I have still not been able to get the app approved.

@natedogg, the app file was created following the course on Codeless Academy. Have you run into this issue as yet?

@emmanuel, I have sent you a few PMs about this?

From the research I’ve done this seems to have something to do with the DNS resolution of ipv6 addresses. I have tried submitting the app using the custom domain, http, https, and the standard domain.

Any assistance would be greatly appreciated.


Hey @pieter, I haven’t experienced any specific issues with the app not loading when submitted.

When I have seen issues with the app not loading past the splash screen, it has typically had to do with something on the web page preventing it from loading or making it load slowly.

Is it having trouble loading altogether, or getting past the login screen? There have definitely been some login issues with many Phonegap apps since iOS 10.3 was released.

Hi @natedogg,

Thanks for the response. I have tested the app using the files provided on your course on two iphone devices. 1 running iOS9 and 1 iOS10. The iOS9 app loads fine with all functionality working.

The iOS10 app (10.3.1 & 10.3.2) does not even load the login screen at all. I have been struggling with this for a few days now and have not found a solution. It seems that it could be related to something to do with the UIWebView vs Wkwebview however I am definitely not sure.

Here are a few resources I have had a look at:

I am not sure what to do next as apple keeps on rejecting the app claiming it to be related to the app not loading over ipv6 networks however I have reproduced this on both ipv4 & ipv6 networks.

Could you recommend any solution?


Hey @pieter,

I haven’t seen this exact error before so I don’t have an immediate solution in mind.

I don’t mind taking a look at your .zip file to see if anything jumps out to me though. Mind sending it to

Thanks Nate. I have just sent the email with the zip file.

Thanks for the help.


Hey @pieter, looks like I didn’t get the email.

Can you re-send it?

Hi Nate

I have resent.



Did Nate ever fix your issue? I’m having the same issue on my app. I figured maybe you all starting emailing each other directly.



Same I having the same issue and need help fixing this. Any solutions?


I have gone through this issue now twice with two apps I have submitted to the app store. My apps got rejected outright every time with this IPv6 issue.

The only recommendation I have is to respond to the review team in the resolution centre that your app will run on a IPv6 network and resubmit the app for review. Chances are they will approve the app.


How did you resolve the blue screen issue? What happened to @NateDogg?

I got the same(?) issue when using Apples Xcode example for embedding a web page. The code works out of the box (, but when changing it to my Bubble app URL I get nothing but a white screen.