AWS Rekognition throwing an error

I have installed the AWS Rekognition API and copied the workflow and repeating list from the example app.

When I load an image and start the workflow I get an error that says Plugin action Detect Object on Image error when parsing the response: Cannot read property ‘length’ of undefined.


Originally, I thought is was because I had no URL to the image (Dynamic Image) blank. However, I took the image URL from the example (//

And it still threw the same error.

When I step through the inspector on the Preview page I found that it is throwing the error on the first step after clicking on the upload button - the Detect Object On Image:

However, when I look at the image in the inspector, it has a Protocol-relative URLs and it does display the image. So I am not sure why it is detecting a property with no ‘length’.

When I look at the actual workflow step, everything looks fine:

Any thoughts?


Hello @lindquisterik1,

Thanks for your message.
The error you are facing means that Bubble’s front-end has been unable to parse the response from the back-end (plugin).

I see that the editor is reporting 4 errors (top-right) of the screenshot you pasted. It might be the cause of the error you are facing, ranging from wrong type within a RepeatingGroup for instance, or another one.

Can you please review and fix the reported issues and try again ?

Many thanks.

I got rid of three of the four errors, related to another page and setting focus. The fourth error is saying Bubble wants google map API’s not sure why that is, but I can’t see how that would affect this page and this function!??

So still not sure how to fix this.

If you have done a copy paste of items from the demo, sometimes Bubble copies the value in the fields and/or the workflow step but is not “mapped” to the actual object it should refer to, and might trigger this error.

I would recommend at this stage to go through each of the workflow step, input, output, types, visual elements and groups that constitute your workflow, and re-select each of the fields from the drop down, including types in the visual elements.

If it doesn’t help, please PM us directly with access to your editor, we will be happy to have a look.

I know what the issue is, just not how to fix it.

I have rebuilt the repeating list, and input all of the dynamic data into the text box (Text Box for Results).
The issue is that the text box options that come up in the “Show” workflow tool is the textbox for my header Title and does not include the text box that is in the repeating list box. I have tried the text box as a separate entity in the repeating list and grouping the text box with the repeating list. If I take the textbox out of the repeating list it shows up in the Show workflow, but when i put it back in the repeating group, it is no longer available.

I am not sure what is going on…