Backend workflow not working with a :SUM

Hi, I have a backend workflow defined which reads a list of data from a JSON file and updates my database in a loop. Everything is working fine except one set of fields that I’m trying to update using a :SUM expression. Here’s what I’ve got:

This part of the workflow updates 3 sets of data (each set has 24 items):

  • qty
  • revenue
  • cogs

Here’s the qty, which works fine:

Here’s the rev, which works fine:

Here’s the COGs, which doesn’t work (no error, it just doesn’t populate my data). “cogs items” is a linked child table.

Any ideas? I’ve tried various combinations of trying to update this field using data from the child COGs table, but nothing happens.

OK…so of course, after working on this for soooo long, the minute I posted here I thought of another approach which seems to have worked. Showing a screenshot here in case it helps someone else looking for the same thing at some stage.

Basically I did a search that still found me "this revenue stream’s "list, but did the search on the COGs table instead and then grouped the result so that there was one line with the sum I needed.

This topic was automatically closed after 70 days. New replies are no longer allowed.