Forum Academy Marketplace Showcase Pricing Features

🎥 Background Videos - New Plugin from Zeroqode

Background Video Plugin - Provides smooth videos for promotion on the landing page, go no further as with this plugin users can set videos as their backgrounds, with possibility to stylize the frame, playback speed, change opacity and more.

https___s3.amazonaws.com_appforest_uf_f1603889693623x863393439282196500_BGVideos PresentationGIF

For details, screenshots and demos please visit the plugin page at: https://zeroqode.com/plugin/background-videos-1603889751555x646533862967915600

Zero Code Conference 2020.

Levon Terteryan

Founder @ Zeroqode

zeroqode-for-web-160x120

Bubble Templates
Zeroqode Blocks
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services

1 Like

Hi there,

I have just purchased this plugin and my video plays on desktop but not Safari.

I can see from the updates that this was fixed though?

If you could help it would be greatly appreciated!

Thanks

Hi @realprojectfalcon .

Thanks for reaching out. Unfortunately, this issue is not reproducing on our side. The plugin is working properly on both iOS and macOS Safari. Could you please indicate which browser and OS versions you are using?

Also, please make sure to configure the plugin as per our doc instructions here, then give it a try again.

However, if you still experience the same or any other issues, please share more details like screenshots and/or a screencast of your app setups, plugin configurations, and workflow actions, so we can replicate the same steps on our end.

Regards,
Zeroqode Team

It is reproducing on my device and those of my customers unfortunately. In your zeroqode forum it says that it won’t work on Safari due to browser policy. Can you please elaborate on that? Apple says differently: Apple Developer Documentation

Hi @janheinemeyer_house2 ,

Thanks for reaching out. Our team will help you via this forum thread on our ZQ threads:

Best regards,
Zeroqode Team

For all of you who are waiting for a simple and faster loading solution. Try this. I am not a developer, but 20 minutes of stackoverflow research gave me this. Just add it as an HTML element. Works like a charm and scales from wide screen to mobile.

<video style="
position: absolute;
left: 50%;
transform:translateX(-50%);
bottom: 0;
min-width: 100%;
min-height: 100%;
class=“video-js”
playsinline autoplay loop muted
<source src="YOURVIDEOURL" type="video/mp4"/>
</video>
2 Likes

Thanks @janheinemeyer_house2 for the workaround.

We have also managed to fix the plugin itself. You guys should be able to use the autoplay feature in Safari as well, but please note that according to browsers policies, still, it is only possible to autoplay when either the video is muted (you can use the MUTED checkbox in the plugin element), or the video itself doesn’t contain an audio track.

To have the latest fixes, just update the plugin to the latest version, refresh your app and give it a try.

Hope it helps.

Best regards,
Zeroqode Team

Hello,

I was wondering if I could get some help. I’m using both the background video app and the backgroundeffects app. I notices that sometimes, the video or effects do not stretch down the entire page based on what other groups I have on the page, and in mobile sometimes the effects cut short, like halfway through the page.

Could you provide me with some pointers as to how I can fix this?

Thank you

Hello @randreas, thank you for your message :slight_smile:

Sorry to hear about the issue you got with our plugins, I would like to help you sort it out.

In order to investigate the errors from your side, please share with use more details regarding your use case. It will be best to share a link to your Editor so we can check everything from our side and try to sort it out.

Waiting for your reply :slight_smile:

Best regards,
Zeroqode Support Team

1 Like

Hello.

Thanks for replying. I believe I resolved the issue.

The issue happens when I have a group, and within that group I place a background effect or video and a text element. If the text element is only set to let’s say 60 height but the text itself is a paragraph long, this creates an effect where the group expands to be longer but the video and effects element do not expand.

The way I’ve discovered to fix this is to simply make the text element as long as the text itself so that it shows everything. When I do this, the group element does not expand, so the background video/effects elements remains perfectly fitted.

Sorry for the bother.

Thank you

Hello,

I was hoping to come back to this and offer a suggestion?
So your background with video plugin has an “enable viewport height” setting that allows the video to stretch for the entire screen no matter the zoom. This is pretty neat.

But the plugin for background with effects does not have this. So when the page is zoomed out to its maximum capacity, the effect does not stretch along with the page. Are there any plans to add the viewport feature to the background effects plugin?

Hello, @randreas! Please accept our apologies for the late reply. :pray:

First of all, it’s great that you have found a solution to your case and shared a workaround for it. Thank you! :slightly_smiling_face:

We have not tested, unfortunately, the cooperation of our two plugins Background Effects and Background Videos in one use case. But it is good to know that you have found a way to use them accurately in your app.


Regarding your request for the “Enable Viewport Height” feature - we will add it to the list of the possible plugin improvements and see how feasible it is to add it in the next update. When it happens, we will announce the update in this thread. Thank you for suggesting it. :slightly_smiling_face:

Please let us know if there is anything else we can help you with.
Regards,
Zeroqode Support Team