Bubble API Connector Issues: Opensea Queries

Good day,

Anyone else having issues with Bubble Connector connecting to Opensea’s APIs?

So I’m getting:

"There was an issue setting up your call.

Raw response for the API
Status code 403
error code: 1020"

Whenever I query Opensea’s “Retrieve assets” call, but when I ran a python script online to call it it pulled the info just fine… I have an API key that’s new as well, just last december.

Also I’m not a developer, I just had some help from the Opensea Discord in testing if the problem was with Opensea or Bubble. Turns out it’s in the Bubble side I think.

If anyone solved this please do help, thanks a lot.

I was having a similar issue (with another API).
The problem is: The website (Opensea) is probably blocking all requests from your domain (bubble.io).
A possible turnaround would be allowing each user to make their own call.
To do so, you just need to check the option “Attempt to make the call from the browser” on the API connector.
It solved the problem for me! :slight_smile: