Forum Academy Marketplace Showcase Pricing Features

🗺 Bubble's Google Map Extender - New Plugin from Zeroqode

Hello Zeroqode team, please help me use map extender in a better way for my app:

A user sees a list of users on load, whose current location is near to the current user (x miles radius) and whose drop point is near the destination of the current user. But that is a limited result.

It never shows those people in a result whose route match is let’s say 80% overlapping current user but the current location or destination is not in the proximity of the current user’s current location and destination.

So if someone is going from San Francisco to LA and crossing San Jose, if a person wants to go short distance within San Jose, and the route matches 100% with the current user, it doesn’t come on the result based on my basic “Searched for user by distance from…” listing logic.

Q1. How to include a user in the list, (for example) whose 5 miles route is 95% overlapping current user’s let’s say 35 miles route?
Q2. How to figure out pick up point and drop point from two different routes on the same map and save it as geographic location/text/display on the map to user data?

Hello @rishidavinci,

Thank you for your question. The user case described by you seems to be a complex one. Could you please add [email protected] as contributors to your app? It will give us more context and hopefully will help to find a solution.
Thank you in advance!

Best Regards,
Zeroqode Team

Hi all!

We’ve updated the plugin with the requested feature. Making your web app to look more native like with this option is possible now.

Update 11/6/19

  • Enable / Disable on screen UI was added.

@cangrimen

Please check the latest version of plugin for the update. If any issues appear with, do not hesitate to post them here with @zeroqode mention.
Thanks for support and understanding.

Regards,
Zeroqode Team.

1 Like

@ZeroqodeSupport

Excellent plugin! I seem to be running into issues.

I have an app that toggles between a regular map and a map with map extender. The idea is that a user searches for a location, then can click a button to see transit/traffic/bicycle path overlay.

My issue is that the workflow works well, however, the transit/traffic/bicycle path layers do not appear at all. See my setup here (Where Map B is the map that the extender is working on, and Map A is the map that the user’s search result is stored on):

Note that the ID attribute is hidden in the screenshots, but is consistent (ie map2)

Any thoughts about where to troubleshoot?

Hello there @samudzi, I suggest you to add layers before showing the map, let’s try this one solution, if it doesn’t helps, provide me with access to your app by adding [email protected] to collaborators.

Thank you,
BR,
Nik.

In other words, in my workflow, “Show Map B” should come last?

Hey @samudzi, yes I meant this, but I can’t guarantee that this will work as expected before I will not test your app, so on lets try to change Show MapB action position to last, try it once, and if layouts still will not appear add [email protected] to collaborators of your app.

Thank you,
BR,
Nik.

I have added you as a collaborator.

Note: I created a page called “test” to try out functionality without the interactive functions (ie hiding/showing maps) that I have on the main page. As you can see, it works fine.

When I copy/paste the same workflow with presence of the other maps, I notice that MapExtender just doesn’t render at all. The hidden map that gets shown renders fine (I tested this by adding a marker - since the Extender overrides the underlying map, if working, that marker would not appear), but the MapExtender does not render.

Debug is not helpful at all, as it shows that all of the necessary variables/states are passed to the MapExtender including the KML layer. The debug does show that a “General Error” occurs, but it is so non-specific that I can’t do anything with it (“Sorry, we have encountered an unexpected error. Please file a bug report (Help -> Report a bug), including error code 1575820757250x267105098126717800 and a step-by-step explanation of how to reproduce this issue.”)

At this point, I’ve just given up trying to do it the old way and built main_copy with a single map (like the test page). KML layering works when I do a search now. Now, just working on getting the layer to load properly on page load. It does when I run debug step-by-step, but not when I run in normally.

Hello, @samudzi

We’ve gotten the invitation for collaboration on your app, we’ll check this out and be back to you with an update on the matter.
Thanks for understanding.

Regards,
Zeroqode Team.

Hello @samudzi,

We checked your application! To make the KML layer load properly on the page load please add a pause before the action display KML file.
image

Please let us know if you will have any other questions!

Best Regards,
Alex.

Thanks for this. I think it works, but right now I am out of the US for the holidays, so will confirm that it works when I return next week.

How can this thing use code from snazzymaps? Really important that it can, it makes a huge difference. Google Maps Extended can do it but you seem to have a more robust solution overall.

Hello @ryan16,

Unfortunately at the moment, it is not possible to add the custom design and use the features of the plugin. We are working on that and once the update will be available I will inform you.

Best Regards,
Zeroqode Team

Thanks !!! I faced a this one, thank you this thread!!!

hi using this plugin I was trying to set up the directions display in the map, just as in the example of Zeroqode, I already put my own API keys for maps and such, and for one moment it seemed to work, but from then and currently, this has been appearing:


can anyone point me in the right direction to make it work?

thanks in advance :confused:

Hello @takagishunsuke1129,

Could you please attach a screenshot of the workflow you are initiating when the error appears? Or a short video showing step by step the process from the debug mode.

Thank you in advance!

Best Regards,
Zeroqode Team

Finally back in the US. I set up the pause as you suggested.

The weird thing is that the KML layer loads properly for every zip code that I look up except for the zip code of the starting location.

In other words, when I first log on, and the browser passes my location info to the app, it zooms the map to the right location, but the KML layer does not load. However, when I do a subsequent search for another location, it works as expected. Then, if I were to search a location in the original zip code that maps to my location, KML layer does not load again.

I’ve checked my KML library to ensure that the file is there, and when in debug mode, I can see it points to the correct URL, so I am a bit stumped.

Hello @samudzi,

From what we can assume, this issue may be caused by the problem with the KML file. Could you please check the KML file that should be displayed over your location. Just try to check it with other KML readers. Please let us know if the problem is with the file.

Best Regards,
Zeroqode Team

I just checked on http://kmlviewer.nsspot.net/ and https://www.doogal.co.uk/KmlViewer.php using the file https://asoba.co/zipcode-kml/zip94901.kml for the zip code 94901. One both sites, it renders the kml properly