Button can't be clicked on iOS safari

Hi Folks,

Out of curiosity, I send the Preview link to myself and tried to open it on my iPhone.

Usually, when we open the preview on a laptop browser, the button is clickable, and the color will change when our mouse hovers over it. But on iPhone Safari, I just couldn’t click it.

Is it normal ?

Hi there, @WildlyOptimistic… I assume you are talking about the Submit Guesses button, and in general, no, it is not normal for a normally-clickable button to not be clickable on a mobile device. One possible culprit is that something is covering the button when the screen size is smaller, so maybe play around with your responsive settings and see if that leads you in the right direction.



Thank you Mike.

Actually, I found out that though the button “seems” unclickable (i.e. everytime I press on it, it didn’t seem response) . However, it had send data back to database, meaning the workflow worked.

It is just didn’t have the “effect of being pressed” .

I’m trying to go back to the editor. But when there are too many groups on one page, Bubble goes crazy, and somehow refuses to give me the work panel of THE group I am trying to work on. Is that a Bubble glitch ?

No, that is not a Bubble glitch… it’s just how it is sometimes. I often use this to select elements that might be difficult to get at on the page itself.


Thanks for the tip Mike , much appreciated.

re. the previous button issue, I went back to the editor and adjusted the button position and make sure it didn’t get attached/covered by any other elements.

However the issue is still there. Please see the editor screenshot.
(And workflow worked again.)

Can you share a link to your editor (or at the very least a link to your preview)?

What is the issue at this point? You are saying you can tap the button on mobile and the button actually works, but it just doesn’t look like it’s being pressed when you tap it?

This topic was automatically closed after 70 days. New replies are no longer allowed.