Forum Academy Marketplace Showcase Pricing Features

Can not run workflows relies on invalid input

Over the past day I have been building a custom input form. Successfully testing and having no issues with workflows until just a couple of minutes.

Nothing has changed with the elements used in the workflows, nothing has changed with the workflows, so I can not understand why I started to receive this message and the workflows are not triggering which renders my custom input useless.

Screen Shot 2020-01-04 at 8.23.48 PM

On searching the forum I came across this post from several years ago with one relatively recent post indicating experiencing the same issue.

There had never been a response from bubble on the issue and it would seem the issue was resolved.

Has anybody else seen this recently? Was there a fix to it, or just randomly go away as it randomly started?

1 Like

BTW I am running conditional workflows that require a do when triggered by the custom state of a shape pioneered by Gaby in this video I became aware of thanks to @rico.trevisan

Screen Shot 2020-01-04 at 8.36.08 PM Screen Shot 2020-01-04 at 8.34.48 PM

I also tried changing the conditional workflow to use another method for setting up the conditional but it doesn’t work either as I get the same message.

Screen Shot 2020-01-04 at 8.48.10 PM

The strange part is that other workflow events which rely on the same inputs don’t produce any errors. I’ve deleted the one workflow action causing the error and no errors are reported when it is gone.

Hey Boston,

Any chance you can put this page into a new app and give us access to check it out? Also, is Input a inputbox?

I’d love to inspect it if you are willing.

Hi @boston85719

Bubble doesn’t call it a bug. I have dealt with this problem quite recently.

The problem with me was that it was marked “This input shouldn’t empty”.

This error doesn’t tell you which input is, and I didn’t think it was possible because this input is hidden in a group. After a long correspondence with the team, I was able to solve it.

Maybe it’s the same situation and you might want to check it out. The best statement from the team is below.

The most likely issue here is that workflow is relying on a field that should be filled out by your user to complete, but the field has been left empty so the workflow is failing.

2 Likes

Thanks for the input on the input issue. I just unchecked the box “this input should not be empty” and the error went away.

I think they made some changes that have affected inputs in what I think is a negative way. Not only the issue, but I also get denied access to pages now if one input out of 10 is using auto bind and the privacy settings are not set on it. In the past it only raised the issue when attempting to enter data into the input, now it raises the issue on page load and are unable to access the page.

This seems to be related.

Thanks again for the solution.

1 Like

I was thinking about doing it. Right now I am styling things according to material design specifications.

Here is an editor with most of the design finished as well…I added the character count using the plugin by zeroqode ( countable )

Was getting ready to do the responsiveness, but all that was needed was for my purposes putting groups on the margins so the input wouldn’t shrink from 540 to 320 until after a certain page width.

Very cool.

Do you ever face issues with ad blockers? I run Privacy Badger and sometimes it marks Bubble as red. Which breaks functionality. Here’s a video:

I’m wondering if more users out there might face the same issue and if there’s some way around it?

I don’t know, but it sounds like you should bring that up with bubble support. If adblockers are affecting functionality it seems like something they would know best. I haven’t seen it come up before and I use adblockers.

Hey Boston,

So I played around for half an hour. Do you like this?


It’s way more simple and the transition is smoother. I am not certain how it will work with responsiveness, but there is only a single input and single textbox so it should be easy. The textbox is “behind” and the input box is “in front”. The text box is taller, and input is shorter and starts about half way down the textbox.

Let me know if this works for you.

image

image

image

image

Enjoy!

@boston85719

I almost forgot, I accidently made two accounts months ago (cell/laptop). If you want to reply, send me messages to this account.

@boston85719

Just noticed a small glitch. Also add to the conditional… Or this text is hovered.

It’s not entirely perfect, but I like it will enough for a quick creation.

That set up at first glance seems awesome…I’m going to try re-creating it and will probably run with it.

Was getting a bit flustered with the conditional workflows I needed on my set up as they don’t copy over, so would be cumbersome trying to create complete forms.

After going through it I will update the thread on custom inputs with a credit to you. Always nice to get alternative ways to implement, especially when they are better.

It’s not quite as flexible as yours, but honestly i didn’t put lots of time into it. The annoying part is if you hover over the text rather than the input, it can’t make you type. But again, just a little thing to try. Bubble is nothing if not a mind puzzle.

I made some adjustments to the setup of the elements. I made the text element the same size of the container with background grey color ( both are 56 px height ). What I then did was change some of the padding settings for things to line up.

Essentially all conditionals are based off of the text element.

I created three different versions of yours. I like the last one which allows a user to hover with automatic focus on input…this requires a conditional workflow event and adding a shape to the group for setting the conditional workflow…however, I think it is awesome.

mutliple inputs

Thanks so much for posting your set up…has really made it 100 times better.

In terms of responsiveness there are no issues.

The editor link is the same but here it is again

4 Likes

Glad it worked Boston!

This topic was automatically closed after 14 days. New replies are no longer allowed.