Can you not delete an entry in a list?

When you use the command “List [field] remove”, the DB entry doesn’t get deleted, only “cleared”.

Is there a way to delete the entry? Or don’t I understand the operations…

Use delete thing and contrain it by something unique.

Sorry @JustinC. I meant [data field] in list, NOT thing as in Data Type.

Updated the topic.

Ok, worked now. I used the wrong operator. I’ll remove the topic as it doesn’t give much value to others.

Thanks @JustinC

1 Like

I would leave it.

(It was a question I had 6 months ago too)

Topic not clear enough.

I’ll post another interesting one. :wink:

1 Like

If I understand the question correctly, it’s something simple I also found myself stuck on because I was referencing the wrong thing.

I created a quick example on the forum app for how to remove a text field from a list. If it makes sense, I’ll make it a top level post so people can find it later.

Bubble´s so very logic but from time to time it´s super confusing. You think you know how to do things, but end up not understanding why it´s red everywhere lol. I guess you just need some good users to push your mind back on track. :slight_smile:

@dan1 nice example. Yours serve as a good one no matter what.

My issue was that I used only “remove from list”, which won’t “delete” anything from the database. This is one instance where bubble could be confusing. It’s clear, “remove”, not “delete”. Well, what can I say lol.

Another instance is that “thing” is normally referenced as “data type”, but “thing” can be anything.

I actually like to think of Thing as “record.” Bubble says “Thing” because it can’t anticipate your data type names, but Thing is referenced a lot more as entries in your database: e.g. “make a change to a thing” , “delete a thing” … “make a change to User/Product/Order/Company/etc.” , “delete a Category/Event/etc.” . You’re not making a change to the actual data type or deleting a type (type names or fields), you’re making a change/deleting records or entries.


Absolutely agree with you! I try to do the same.

When you structure something in a workflow, it’s easy to understand [thing] as a data type, because the structure is hierarchical. However as you point out, it should be viewed as a general term.

1 Like

oh shit, i think i tried to view your example i changed smthg!!! sorrrrry!

@dan1 Can you put back the workflow of delete? thanks.

Missed your request here earlier. In any case, just applied the fix.

Screenshot below