Forum Academy Marketplace Showcase Pricing Features

Can't get image URL, just base 64

Hello,

I searched the forum and found similar problems, but no answers. My app has a data type called Media Item set up like this:

I set up a Backend workflow to expose an API to upload an image and create a new Media Item. The good news is it works! I see the new images in the data. This is a call to set it up:


The payload is a base64 PNG for testing purposes.

The problem is that Bubble returns the same Base64 and not a URL to the image:

This is how I’m returning the URL after the Media Item is created:

Do I need to create the Media Item in a different way? Or add another field to my table? How can I get a URL to the online version of the image?

Thank you!!

I think I am getting a little closer with this, saving it to S3:

But that now returns a 500:

I tried this when creating the entry in the data table and a bunch of other permutations. Still no luck:

I can’t even get the image to upload…

Can you use the API connectors somehow to convert it to a file?

how were you able to upload the image, even as base64?