Forum Academy Marketplace Showcase Pricing Features

Collapse repeating group rows if not enough data

One problem I often encoutered multiple times is when using repeating group that can potentially display lots of data, but that are not at the bottom of the page.

In that case, we might want to use the option “fixed number of cells” to only display part of the data and then use “next/previous page” action to perform pagination. Indeed, using another option such as “ext. vertical scrolling” could prevent the user from seeing the content at the bottom of the page if there are thousand of items to display.
However, when you are planning on having let’s say max 20 items per page, but have only 2 items to show, the repeating group still keep 8 rows totally empty.

Since in that case the repeating group is not at the bottom of the page, it creates a huge gap between the end of the displayed content (the seocnd row of the repeating group) and the group below the repeating group, which is very ugly.

It would thus be nice that the repeating group somehow collapse empty cells to avoid that.
Note that the answer “put your repeating group at the bottom of the page” is not an option here.

I also think there are workarrounds using custom states, and maybe item from# until# with a repeating group in “full list” mode, however ths is just another trick for a feature that could be built-in…

8 Likes

+1 was just searching for a solution for this

1 Like

Any updates to this issue? I’m looking for a solution to this. Something like ‘fixed number of rows’ would also work, especially since the page is responsive.

Yeah I’ve been looking for this for a while. As specially with image sizes, if the users image ratio is wide, it should collapse the cell

+1 for “max number of cells” option on repeating groups.

Hi @florent.bocquelet , I am experiencing the same issue. Please let me know if you (or anyone else reading this) has found a solution to this problem? And may you please elaborate on what you mentioned when you said:

“I also think there are workarounds using custom states, and maybe item from# until# with a repeating group in “full list” mode”.

I have tried putting the repeating group into a group and checking “collapse this elements height when hidden”, however no luck. I would really appreciate any assistance.

1 Like

Still waiting…

+1 Is there an official response to this yet?