Forum Academy Marketplace Showcase Pricing Features

Columns not showing up in database

I noticed this some time ago, but so far it all worked so it didn’t bother me.
It is making debugging much harder though, and now it’s giving me trouble in data search as well.

Basically, some of my data types have up to 15 fields, and the “app data” tab only shows up to 7.
In the “data types” tab all the fields show up as they should, but in app data it looks like some columns were never created (even if I’m sure I have entered data for many of them).

I always assumed that the data is saved and that it’s just a limitation in the viewer. I tried to download the data though, and again, there’s only 7 columns.

Did anyone experience this? Am I doing something wrong? Is this a bug or a limitation?

1 Like

Hi,

Under the Data --> App Data tab, click on the “New View” button.

In the dialog box that pops up, name the new view something (if my table is called “Pets” I usually call it something like “All Data - Pets”) and then select the table you want to see all the fields on (i.e. “Pets”).

Once you do that you’ll get a new dialog box pop-up that shows you all the fields you can possibly see for that table. Click on the checkboxes for the ones you want, then hit ok and you’re done.

In the App Data tab, now (near the top of the column) you will see your new view. It’s a bit confusing b/c now you have your original Pets table (which might show, say, only 7 out of 14 fields)… and then you have your NEW Pets table (e.g. All Data - Pets) which has, say, 14 out of 14 fields (or however many you selected). But in any event at least you’ll be able to see all your data as needed.

Super easy to change at any time, too - just click on the edit icon next to All Data - Pets table and select/de-select fields as you please.

Hope this helps,
P

4 Likes

Wow thanks a lot @scriptschool, this is gonna make my life so much easier!
I just assumed that creating a new view would enable me to restrict the range, not broaden it… silly of me

No probs!

Best,
P