Connect One App to Another

I have seen this been done and would like it myself but have not found out how. I have 2 apps and let’s call them Dashboard and System. Dashboard has all of the main information and that’s how everything gets set up (Ex: Users). When a user tries to go to System I want it to use information from Dashboard so when a user tries to log-in it makes sure the user is logged into Dashboard and uses that information and it checks for something like if the user has a value of admin that is true if so log the user into System.
Please let me know if you need better clarification or information.

You want to install the Bubble App Connector found in the plugins.

Correct, as @robertjhill0 mentioned, you’ll want to use the Bubble App connector for setting this up.

I have a Learn Bubble lesson that provides an introduction to getting started with the API connector. Here’s a direct link to the lesson video.

Only issue i have seen though… (might be a bug) is i can’t use the bubble connector is i can’t use it as a value when using it in a search criteria (i can use the API connector) but when using the bubble app connector theres no button to add it

@dan1 question for you… Does there have to be any special privacy settings? For example… I have 2 bubble applications connected… I also have the API connector set up using the same credentials and calls. When I use the app connector to retrieve data in the 2nd application the only way I seem to be able to have access to it as if I make everything available to everyone… Whereas the API using exactly the same credentials and calls works without any issue

In the bubble app connector you need to specify your using a API Secret

@robertjhill0 yep got that thanks i am referring to bi directional access. App B the sub app which is OAuth i can place the api key Client ID and secret …get all my stuff in app a no problem…but and here is the thing… in app A you can only put the token with authentication as API key… this is the issue… i cannot get my data in app b unless privacy is off. but using the same token in the API connector works.

@robertjhill0 I think I understand the issue you’re encountering. When you use the connector, the data types are not going to appear under the “Do a search for” section. Rather, you want to use the “Get data from an external API” action. You can apply constraints there, just as you would with a search.

Let me know if that covers it.


Let me take a closer look at what you’re describing when I’m back home. I haven’t personally tried implementing bi-directional access between Bubble apps and had privacy roles at the same time.

Might be helpful for me to understand if you draw it as a diagram. (App A and App B - what’s being shared, who’s accessing what form where).

This all works but when it comes to using things in App B you can only access them as their Unique ID…funny if you turn privacy off in App B then it all works…“yes i know about privacy settings in general and in regards to api calls” The exact sames calls in the API connector using the same credentials work fine but you cannot access the data type of course.

Have you tried using the Inspector tool and tried gleaning anything from a data standpoint there?

May help if you can share a few screenshots of your setup in the API connector in a private message? (Feel free to block out sensitive fields).

With your privacy roles, do you have multiple roles set up? Are you referencing nested objects (ie. unique IDs on one table that are from another table; ex. a list of customer’s booked appointments)?

Thanks Dan, yes Inspector and console too. Interesting you mention “Are you referencing nested objects” that seems to be the nub of the matter… not an issue with the native API connector which is what i cannot get my head around as i presumed they two are pretty much the same.

…so my intended outcome is to get a list of things …these things have their own DB type and i assign these to a user as a list of things…

So as as example

Whilst in app B

I can get a list of users in App A (super)
I can get a list of all things in App A (going well so far)
I can create a RG of users and get a list of the things when the RG type is user (outstanding)

Now if i set the RG type to the thing which i need to list (bearing in mind i can create a RG of these things for all users with out an issue) I get back a big fat zero… nothing in the inspector.

If i make the same call via the API …it works.

are you aware of an issue when referencing stuff in nested objects via the App connector

@dan1 just for completeness… as i can list all the things in app A from app B i can filter these to current ‘app b’ user …app A user if that makes sense.

From what I read, it seems like nested lists are functioning correctly. But searches are where the failure point is. Under your privacy roles, two things come to mind:

  • Do you have any privacy roles where “Find this in searches” isn’t checked, where this may restrict the flow of that data?
  • Do you have any privacy roles that show “Rules that use “This User’s X’s Y” can’t grant search access right now”?

Thanks for the aircover dan… yep one of the very fist things i checked and re-checked and then recursively validated. “Find this in searches” is checked for all privacy roles. I think this very well might be a bug…on occasion im getting "Error connecting to a Bubble app: Missing object of type xxx: object with id 1531493967017x251280224173686800 … and there is no object with that ID. i will see what i can do to narrow it down

Last one is a long shot (because you referenced an exact unique ID there).

o you have any workflows that are dependent on referencing an exact Unique ID (that you’ve pre-determined within the workflow; not something dynamic)? If you did that, but didn’t reconfigure between test and live, that may be a source issue.

@dan1 right but i am doing it in a workflow… so basically for example

they click a button in the WF i have create new thing. Name = it does a lookup via an email for example to the other bubbleapp and it’s supposed to get the name and put it in the table but im not able to use it in that function is it a bug?.. if i do it though just the API Connector it works.

Really not sure without being able to interact with the app.

If you’re able to access the value otherwise, you could store the value in a non-visible input on the page and then reference that field in your workflow.

Thanks Dan for looking over my shoulder and playing devils advocate…no …but that seems to be only only item in the thing i can get back.

For anyone else find themselves here…i’ve noticed spurious items in nested objects that don’t exist killing my APP CONNECTOR ‘USE DATA CALLS’… stuff that’s been deleted but i can actually see these items in API calls but they are not showing in my DB.

Very p[possibly me doing something wrong but i’ve raised a bug report

are you using OAuth or API? for the thing you are looking up