Copying API in API Connector removes all instances of API

I duplicated an API in the API connector, and all references to that API were removed. I contacted support about this but there have been no updates in a few days, so I wanted to see if anyone else experienced this.

Hey @dramirez

Hmm :thinking: Hope support will get back to you soon.
Have you tried restoring your app to a previous version before you made that change?

I notice that if I copy an API connection and paste it, it overrides the one that I pasted on top of. Undo doesn’t fix it either. It’s pretty dangerous. I tried telling Bubble but they don’t think it’s an issue. :man_shrugging:

I want to save restoring to a previous version as a last resort since it changes the unique IDs of records and I rely on those for some integrations.

It’s kind of scary that they are not taking this issue seriously; one small change can wipe out hours of work.

I don’t think reverting app versions affects your database? Thats what the “Copy and restore database” button is for

I’ve also had weird issues duplicating APIs. In my case, while I changed the name of the duplicated API, I now have multiple data types with identical names, and I get errors if I don’t pick the right one (the newer api is the second one in the list :wink: )

Anyway, @bubble there seem to be various bugs with the duplicate API function!

This topic was automatically closed after 14 days. New replies are no longer allowed.