Custom Font isn't happy

Hey there,

I’ve used custom fonts on many of my web apps, but I seem to have come across one that just does not want to work.

Name: Museo Slab 100
CSS File Path:

Site to test:

Can anybody give this a try and see if it works for them? Or maybe I just buggered up somewhere and am having a brain fart. Thanks!

Working for me on my mobile phone. Not near my laptop to test there, but will corcle back when I can.


Hey Andrew,

Tried on both Chrome and Firefox - desktop and no luck I’m afraid:

I can see the fonts loaded in the network tree:

One thing I noticed is that I can see any font specified in the style atrributes on the div:

Maybe double check the font is assigned or even try using .eot or .woff formats as well? As it seems the CSS only comprises of .ttf

If you need me to check again lemme know.


Interesting. I’ve tried both otf and ttf, but will try other formats. I’ve NEVER had issues with this before, so maybe I have bum font files. I’ll give it another go.

Thanks for checking in @luke2 and @jballou

@andrewgassen I was just having the same issue, and I’m not sure what did it but the one I just tried is working now. Let me know if you’d like me to give it a try with the font file you have!

This topic was automatically closed after 70 days. New replies are no longer allowed.