Custom oauth setup

I’m trying to connect to a third party API, and am struggling with the proper way to set up it’s oauth credentials… This is what I’ve entered:

When I try to make a call, I get the following error: Invalid grant_type parameter or parameter missing

It does this regardless of which grant_type I use of the available options in the documentation, which makes me think I’m just setting it up incorrectly. Any suggestions?

Can you share the doc of the API? Will be easier to help you.
For json, you need to set the header to Content-type and application/json

Sure: wallabag API documentation

The link doesn’t contain auth info.
Did you test with the header?
Example use HTTPie, I think default behavior is to send a json with the parameters.

Just tried and worked for me with a GET request and sending the params at the end of the URL as any other:

URL Example:
https://app.wallabag.it/oauth/v2/token?grant_type=password&client_id=1_3o53gl30vhgk0c8ks4cocww08o84448osgo40wgw4gwkoo8skc&client_secret=636ocbqo978ckw0gsw4gcwwocg8044sco0w8w84cws48ggogs4&username=wallabag&password=wallabag

2 Likes

Awesome - this works for me in postman. How do you configure this in the API Connector plugin? Presumably I need to use the authentication section to pass the token onto subsequent calls, right? When I try custom token w the url, leaving params or headers blank I get the same error response…

Yes for subsequent calls you need to pass the bearer token in the Authorization header:
In the API connector set the request to “Use as: Action” so you can use it in a workflow

You can grab the token from a sample request to initialize any other API connector call that requires it:

In this example i created another request for addEntry(with GET method and params at the end of the url), and added the header “Authorization”: “Bearer <token_here>”, make sure to uncheck the “private” option so you can change it on any call from the workflows

And finally, you can call the requests from the workflows > plugins section and pass the token dinamically:


You should also just use the same url into “Custom Token oAuth2”. This way, Bubble will also handle refresh token and you don’t need to pass the auth header in each call. Bubble will set it

4 Likes

As indicated above by Jici, Custom Oauth2 will look like something like this

2 Likes

Super helpful - I’ve got authentication working. Only issue now is GET requests for add entries don’t actually add entries (seems like it ignores the params and acts just like a normal GET to pull in entries), and POST requests return an internal server error.

Actually I think I can work with just the GET Request. I think I’m good. Thank you so much!!!

2 Likes

By the way in your original call you forgot the quotes around the variable names so unless you explicitly put “” in the fields (which your probably didn’t - just a hunch) that’s gonna cause an issue