Data is not written the first time

Hi all. I am trying to write the result of a calculation to a database. However, for some reason, these results are recorded only the second time. I went through all the options, I can not understand why this is happening. From the first time, the field where the results should be written is empty. It fills up only the second time. In this case, the calculations are carried out correctly. I don’t understand where is the error.

The result is calculated correctly. I’m trying to write it to the database


Type of field

I don’t remember the exact circumstances, but I believe I had a problem, similar to yours quite a while ago.

What I ended up doing was performing the updates of the thing into phases. The first update just handle all of the simpler, more straightforward fields. That was my Step 1.

My step two was to update the results of step one. There, I did buy more complicated calculations.

It wouldn’t take you much time to try it out to see if it helps.

1 Like

Hmm…my guess is your issue lies in Step 1. Perhaps whatever you’re setting the state as is not processed/added by the time you run the change to the database thing. Try adding a pause between those steps OR add a new workflow that runs when the state is not empty.

I could be off here, and I’m sorry if that’s the case :crazy_face:

1 Like

it works! Thanks a lot. I’ve been scratching my head all day over this problem, everything turned out to be very simple

thanks for the answer. I tried to do as suggested above. It worked. If you have a similar problem, do not spend the whole day solving it like I did, but try this option right away))

This topic was automatically closed after 70 days. New replies are no longer allowed.