Data No Longer Displaying From Database

Hi All,

Not sure if this is a bug or if it’s something I did. I have a database with a bunch of data and various pages that display the data from the database. Everything has been working fine for months and all of a sudden today, any page that uses data from this database no longer displays the data. This is only happening in the Development version as of right now. The Live site seems to be working fine.

The database itself still has all the data in it, but I did notice if I delete a record, it doesn’t update and actually delete - even after refreshing.

I was playing around with the Privacy Tab and set a couple of roles for the database (which were then deleted) and not sure if that effected it? If not, could it be something else or is this a bug?


That sounds definitely like a privacy issue. I’ve seen it many times myself. Set one of the tables privacy to Current Use is logged in and if it is visible then you will know for sure. And check that the correct checkboxes are ticked so Do a Search for… and viewing fields are checked.

Thanks @patricia! Ya it was a privacy issue, the weird thing is I deleted all privacy roles but my app was still applying the ones I previously created. Now, the only way I can get data to appear is by keeping them. Should that be happening or can I permanently remove the roles and revert back to the data showing up without any privacy roles?

You should be able to delete privacy rules without a problem. I suggest you report it as a bug and ask Bubble to look into it.

I’m experiencing the same problem. No issues, until I tried creating data roles for all my data types. Now my RG data isn’t being displayed. Did you your have to re-create all the roles first?

Update: I tried to re-create the roles to the best of my knowledge and things returned to normal.


Hey @sharifa, ya. For now I reverted to the roles I had previously created, but I only had an “Admin” and “Everyone” role which was pretty easy.

I’ve filed a bug report for this as well.

Update: If anyone else has this issue in the future, Bubble suggested trying the below:

“If you encounter this, it may be likely that you need to delete your browser’s cache and cookies to prevent cached data from interfering with the app’s javascript package. It’s important to delete both and you will be prompted to log in again. Next, restart the browser (or open the page in a Private / Incognito window).”

Hope this helps!

1 Like

@JP29 Thanks for following up and sharing!

1 Like