Database trigger not working on User type, and updates not percolating to UI

5 total or 5 only on User change? If the latter, try to leave one on User change with no conditions and do all actions inside it with those conditions applied.
Generally 5 triggers in total is not many, the main problem is that each type must have only one trigger, that’s the idea. Though I might also be missing something, but that’s the way I managed it in my project.

There were 5 total database triggers on Users, I reconciled them in to one workflow like this:

With the individual conditions on them. Still encountering the same problem though.

It seems like the entire workflow doesn’t run, I put something inside without a condition and that doesn’t run either. Is it because I’m modifying a list on the user, rather than modifying an individual field? It’s not a relationship.

I’m not sure if your condition is valid there. I suppose bubble considers two things equal if they have same unique id. Though didn’t tested it. But if I’m correct, then this condition is true only when User object is created. In any other case it’s false.

Hmmm. Is there a way to do a deep comparison?

Oh duh. Just don’t put a condition. Okay.

Don’t know. I think it’s only possible by JavaScript or plugins. You could create one, if there’s nothing in store.

But is there a real reason to check entire object? If you trigger is invoked, the object is
probably changed.

Yeap, it’s that simple.

Still doesn’t work for some reason, nothing in the database trigger is running. It’s like the database triggers are bugged. I tried doing something else with a different data type and it still doesn’t work.

Silly question, but are you on a paid plan? Triggers only work on paid plans.

Very much so! On a production app.

It appears they are broken across my app. Could you verify that database triggers are working for you?

Oh, I see. You are expecting trigger to run when you add an object to User’s Notification collection. That’s might be a problem… I’ll check this when reach my desk… Never did it that way. Though bubble presents list field as a property, I doubt it monitors list content for change.
Meanwhile you can try set list instead of add: User’s Notifications set list User’s Notifications :plus item Result of step 1…

I tried what you’ve suggested, but unfortunately it didn’t make a difference. Things that were unrelated to this aren’t working either (I went and tested some other database triggers on our app) so I’m assuming there’s something wrong with Bubble right now. I see a similar bug in the bugs board:

I heavily really on triggers in my project and it’s working, tested just right now.

Hey @scalethej

Are you working in version-test? Or are you working in another development version you’ve created?

For me, all triggers I set up in versions other than version-test, stopped working. In version-test, everything works fine.

Can you confirm that your triggers have been set up in a version other than version-test?

I am also having issues with triggers and items updating in real-time for users. I do most of my dev work in a version that’s not the default “test” one if that helps @Bubble.

I’m writing this on the behalf of @scalethej since his forum account is new; so, his posts are throttled. It is on a different version than Development.

Very sorry you’re having this issue! Can you file a bug report for this case? We’ll need to look at your application, and then the success team will be able to assist you.

Thanks!

FYI the issue has been resolved

1 Like