Deleting a File

So when I set a trash icon on a repeating box, it does fine at deleting the “current box’s …”

However when I try to do the same for a file it shows as a red error.

You can delete a “thing”, but a file isn’t a thing, it’s just a simple type.

Ok so how would I remove the file from with the use of an icon?

the way you do it is you just change the value of the field at the thing level that contains the file. In this case, you change the ‘current cell’ and say file = ‘’

1 Like

Worked like a charm. Thanks

1 Like

Hi there! I have the same issue.
So after reading this my question is what do you meant by “change the value of the field at the thing level that contains the file” ? I guess that you have to make the file a type of data instead of a field of an existing type, right?
If yes, there is any way to delete a file without making it a type of data?

thanks!
Mauro

Hello,

I am struggling to delete a single image from a “image field” in a Thing by clicking in a Trash icon or a button. Basically i tried diferent ways of doing this but with no sucess.
Is there any new way, that i am not aware?
It seems like a very simple step, but bubble doesnt have a direct aproach.

Thank you
Miguel

Hi Miguel :slight_smile: There are two different ways. If the image was uploaded by your app, you can delete the file as well as remove it from the ‘Thing’ it is associated with. If you’d like to keep the file in storage, you can also just remove it from the Thing.

For example, if you have an image field called “Profile Picture” within the User data type, the workflow to delete the file and remove it from the User would be this:


(Removes it from storage)


(This sets the field to be blank)

2 Likes

Thank you so much for taking your time! It’s working like a charm now. I was missing this second part “profile picture =”

All set :slight_smile:

Miguel

1 Like