Docspring API image upload via URL

I am using the Docspring API to fill out documents via bubble. I have followed the documentation and I keep getting an error when I try to upload an image. When I delete the image and only use text the document is generated fine. The documentation says to to append “/url” and although I am doing it my document is not being generated. PLEASE HELP!!!

Hi @jovante.ham,

Looking at the API documentation from Docspring it seems you have 2 options, either provide the image base64 encoded or a URL:

Assuming you are using their POST submissions API, this is how the API call in Bubble should more or less look like:

1) Base64:

In the workflow the action will look like this:

2) URL:

In the workflow the action will look like this:

Note: Just make sure, when using the URL-opion that you are not using an image that has been marked as private, because it will not be accessible from outside Bubble.

Good luck!

Gerbert
MVP Design

Thanks so much for the guidance


@gerbertdelangen I set up the exact way you told me and now it tells me it can’t find api token I used. I used the secret token and I know it works because without connecting through API connector I can send text. I have included a picture in this message:

Hi @jovante.ham ,

Http error 401 has to do with authentication, did you setup the authentication settings like DocSpring specified here:

Using the plugin base64 you can encode your token id and secret like this:

You should be doing this in a backend workflow to not expose the token id and secret to your users btw.

Thanks for your time @gerbertdelangen but I tried it that way and still couldn’t get it to work. You recommended I use the API connector but when I only used text I was able to use the workflow and not bubble Api. I kept getting the same error that way even after following your instructions. The instructions say that the sending of images should be just as simple as text and I’m wondering where I’m going wrong.

it tells me to use image/url as key for my data and enter the URL into the value field.

I have shown screenshots of my setup. Do you know where I might have went wrong because it is telling me the image is not sending.



Hi @jovante.ham,

It looks like you are doing it right, it must be a small thing somewhere.

Bubble has the option to allow others to have a look & edit your app. If you want I can have a look and try some things, just send me the link to the editor in a PM.

Hi. Did you manage to figure out why the image URL gave an error on the question above? I have exactly the same issue and I have tried many things but cant find much info on this matter.

Any help would be greatly appreciated, thank you

Hey Sean,

I forgot, by maybe @jovante.ham remembers?