Dynamic repeating group row height

I need help on making my repeating group’s (RG) height according to the size of the sub RG inside.

I found a prior post from 2020 that showed exactly what I’m looking to achieve but didn’t show how to achieve it:
bubblesample

I set a minimum size for the parent RG, and tried setting the sub RG to be hidden and only show if there are lines…but the main RG isn’t changing height at all to accommodate the sub RG, and so I end up with this:

Thank you for any help you can give!

Do you have a maximum height set for the parent RG? If not, can you post screens of the RG in the editor and the element properties?

There isn’t a maximum height option available. Here are the screenshots of the edit and the settings. Thank you!

I also tried making the sub RG shorter but then it just becomes a scrolling box.




Set the layout of the RGs to column. In the child RG, set the min height to be the height that’s needed to show 1 row. Then in the parent RG adjust the min height to be enough to show the contents of it’s cell and the first cell of the child rg (or 2 if you’ve set that as the number of fixed rows).

Have a look here:

Thank you - this works!

1 Like

Another related question, if you don’t mind - I’m looking to do the same thing for another screen, but on this one the RG row is very wide and I’d like it to be able to scroll horizontally so the user can see the other fields if they want. This seems to only be possible if the RG layout is “fixed” - is there a way to achieve this? Many thanks.

No, the RG layout doesn’t have to be fixed. Have you searched for a solution at all? A quick google search will show you tutorials and forum posts about this :slightly_smiling_face:

Yes, I did a lot of searching, but I couldn’t find anything and it seems if I use the row layout all the fields outside of the width of the RG then wrap…and I want them to be there but invisible until I scroll. Here’s my screenshot, showing the fields before I reduce the RG width:

and the same thing when I reduce the RG width…

OK, somehow I fixed it. I’m not exactly sure what I did to fix it - just played around with various combinations, but one of them worked!

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.