Why the scroll bar shows on RG's?

Hi all,

Has anyone found that the repeating groups always show a scroll? I am showing a list of option sets here and the height is ‘fit height to content’. It’s as if the repeating group is about 3px too short and so shows an unnecessary scrolbar.

have you tried removing max height?

There is no max height, height is infinite.

I think css to remove the scrollbar is the only option.

This worked a treat: How to Get Rid of Scrollbars in Bubble.io | Nymbl Blog

Can I comment that this is not a solution, it’s a bypass of a problem. Why does a RG add 3px of scroll when the settings are all set to fit height? Removing the scroll bar doesn’t stop this nagging little scroll from being created, it’s almost as if RGs add a tiny bit more height than needed when calculating. Is this actually a bug ?

Context: just spent an hour with parent and child groups / RGs trying to remove a new instance of this happening, no combination of settings has yet to disable the nagging 3px scroll.

The solution is to create a RG and add a group inside, I call this a ‘Group row’.

Set the Group row to 30px high
Set the RG (appearance tab) hieght to 30px.

This typically works for me, but making the Group row’s height more than the RG row height also works.

Hey @darren.james7518 thanks for taking the time to reply. I tried this and yes - it does work. Woo! Appreciate it.

It still feels hacky, like we’re working around a variable height problem. I’d be ok if it wasn’t adding just 3px! Too obscure to be a feature.

That’s great @manipaje, yes it does feel hacky and it took me ages to figure out what was going on, it’s one of those issues that shouldn’t be an issue!

1 Like