[edit] How to convert an image link to an image I can save - [old] Image error in database

I don’t know how else to say this other than images are “disappearing” from my database.

When I initially store the image, everything works fine. Then, after testing the various workflows a couple of times, the image disappears. When I check the app data and the specific entry, the little preview of the image is gone, and when I click “see” I get this: {“message”: “Internal server error”}.

Where do I even start to troubleshoot this?

Check to see if they are there in your File Manager if you know the names would be a good starting place.

Thank you. They are not in my file manager. Does that mean I’m doing something wrong when I save them?

Are you just making a change to a thing and then assigning the value of a field of type image to the value of a Picture or File Uploader?

I’m saving an image that I get from an API.

Here’s the data type:

What does the saving process look like? Is the API an action and then you are saving the image by using Result of Previous step?

I’m making changes that are the result of the API. The item is called “wheel_image”.

Here’s an example of what is returned from the API:

“wheel”: “https://4boj95dp52.execute-api.eu-west-1.amazonaws.com/stage/chart?payload=F6gkGnFk2vyHT1oqp%2Bw0W9iA5JDgazTyEplsZr0ayU7znlwaRbTXBz7mnE%2F7qrAvaHnjXlORpp5uDmToyZgZFC4KZVsuUgHcb4NTCsPodOfgHW5JCY4RQ0f5XDPufluFpD0vfPa4%2B9CbFggZTeN%2FIe%2B41e95ts%2BIgSGD7DG86uXCBFAm4nh4THbIEvhj9Y2CbZ85KdWK2r%2BgDhr9ES%2Bvsr%2BM6c9%2BoTf%2BJO%2FnvLk%2BWsnxRI4PC2ykdckg0w5wLlFtldFOSIZIjwOFuFY8SX6%2B81GVPgqABgBOSb0l78U%2FPTiCbiv5Q4V4YTpC2p%2BOmjZsQhZPQi8azFPNinr4hA2h8vUwl%2B1h5KRcLCz3vUJDM4ug3qbTpnl2TagWpekZlVoFAOdh56AVvxYcBEbt1W%2BNsUS5lL0BV2V4tu3UxbZlES21GUeKLMW3ChgoAQfwz1aP%2B7sf0%2Bo9%2FTkqge%2BjnyzU58Ma8J6TT9eDSpJubKUtE39XkJPZEwgmxygsPGSCK1HcTQxFPe9OT8W%2BXWOFs2Hxc1f7jsRz%2B%2FOHJJJsC9qN9m5c4%2FliKY77LdOoOFtuKIMRIDkmjcgsv7Zq2wcvAYrzWXsw5tVNOox%2Fh%2Bd4l6WPVitxW2JeF5DXLoPilPD5VS1BalwqA7mgsMJ5VTdLUsuRlxYAWSIejyJb6VtxKGQbs2n5KPYpp7stN4Jiy4RWz34VJBIH1UhLD%2BVY3NLEJytxpSlq4mClBKsmK4pRDltMyPiqQU7HxlItpoL5nUUm7kUDpbvPfF4QhaVS9tOtSg6IZ5GVgKqULKyGlC%2Fah%2BuHZJCpxxCJ8koGGg4Cp9U6bZyQYvSd9MmFprRLL913dydWmQ4lUMjsQuBnFCdU7eren%2BXRkyAIHE6VVp3DA617XPFdm0dFi2BxhS8PVXcdwA8C4IwVER%2Bv4NKpe9q9BwYtWrXUYm3%2FGwWtiji0LgT47aDGhYW36Dt0q0a7ODp33J254frYKJX%2Fz4S50%2F9qCqGutmwp1HAM5NsbdyZ6zV6p8ztx64pbiYr3%2FuDmOrBobTCL%2FBmd3wdQ45Vl04RqaY9XuRKZ19wX7i82%2BASS1KpHs027l88gOb%2BXkjU1JPY86kAQHPEvTpPeB7JURn0rkFUO2zPNMgvQ2e8QpfC1JjR%2Bcd2hsMw7oK7%2FBnFjksELiU1A%2B%2FcyG8kYiYgSIBmdqHGZzQ2gbFpKX%2FpJY%2BU68uyB3rwdw1mfj8BkwwwUrWo0lDC%2BwHp%2Bv9VHiegnoU4jUzo21QO08bsIZEVilPCHd4NB36UXlyXfTLS7qHZCu9aOto9WuJt8EPqivIi4ijdfdYltBhoEVWaLcaM9xN1Zh5EpswBNE38LrXtbO4Psv0GSst1gPW5ptPFHw74tm0Ilmnob8Rw8C8qeec7X4h60%2BzN1da8CsSYam5owmlINCiqgg482Nu71UIprzJV8oVosKvZxGhKNaOmf5OrUY3ZoUMzPOD4MIbRxqXDQ%2B3ygTu4mCoyG1NSV3l4dEwRkLgk8BFhLh%2F%2F%2FMFGklxiatLIdhSW9dCNh5xSl1RRGOYcIc1qyjKUN8iCki4l6HT2RsAO8%2B1UbpxpqvbTaseQztnNUpVtEoEaYJqd1yXXEBRpy5PoHIDtVLtDRwgbvapp1CSmeenal12qoQhBw%2BQi3PMknFyQq2fpDBw%3D%3D&token=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpc3MiOiJhc3Ryb2FwaSIsImlhdCI6MTY4MjU0MTc3MywiZXhwIjoxNjgyNTQ1MzczfQ.qb6Q5dP-osPdR6wXAIPw0j5Pvc7e0WPXRaRNBO2kOEY

I’m getting the same thing. Image (eg. an icon) shows up fine, but disappears when running a workflow.

2 mins later, it’s suddenly working again.

OK. So at least part of the problem is that the image link is expiring.

I guess the question is, how do I convert a link to an image that I can save permanently?

I figured out how to sort it out. At first, when I tried to save it as S3 I was getting an error.

Then I realized that I wasn’t setting a file name and just using the default setting. Once I set the file name, it worked. I assume that’s because the original link was too long.

Screen Shot 2023-04-26 at 9.18.47 PM
Screen Shot 2023-04-26 at 9.18.55 PM