Forum Academy Marketplace Showcase Pricing Features

Error 400 (now 524) When Rendering Plugin Preview

I’ve already submitted an official bug report on this, but I thought I’d also post here for the benefit of others (especially plug-in devs).

While implementing an edit mode preview for a plug-in I’m developing, I discovered that exceeding about 2K characters for the preview function results in the error shown below.

This post references the same error, which is also occurring in edit mode. I don’t know if it’s the same issue, but it seems related.

No word yet on a fix, but it has definitely put a damper on my plug-in development.

Have you found the preview feature useful AT ALL? It’s basically a non-starter since it doesn’t have the instance object. Any properly configured visual plugin will support multiple, differently styled instances, so the preview func as it stands now just isn’t super helpful.

(Read as: the bounding box is fine at present.)

1 Like

What led to my discovering the bug is that I decided to actually provide useful feedback during plugin configuration instead of simply a static image. So yes, I have found it useful in this case.

That said, I agree that, without the instance object, it is far less useful than it could be. For one thing, I was forced to replicate some code, and that would’ve been unnecessary if I could have referenced some constants and other data that were set up in the initialize function.

In the end, I was able to achieve the desired result, but it wasn’t as simple as it should’ve been.

The worst part, though, was that, given the nature of the issue, I suspected a logic or syntax error in my code. I’d remove some code, and things would work. I’d “fix” it and add the code back, and it still wouldn’t work. Then I’d remove some other code, and it would work again. That process confused and frustrated the heck out of me for the better part of a day! Then I removed some comments, and things worked. That tipped me off that the issue was likely related to the size of the function body. I was really quite annoyed that I had squandered so much time on it!

My landlord is not going to be pleased with the holes in the drywall made by my head! :crazy_face:

1 Like

This issue is still present, but the nature of the error has changed (see below). I sure wish I could update / add detail in an issue tracker. I have no clue what the status or priority is for this “feature” which doesn’t work.

I realize that one measly plugin is likely not a Bubble priority; but in my experience, it’s not uncommon for such problems to be “symptomatic” of other issues (or potential issues).

(Sending an email to request a status update is inefficient! :slightly_frowning_face:)

EDIT: Here’s a bit of info about the error.

Hello! Our engineers have confirmed that the issue is with a lower-than-expected character count. A fix is currently being pushed, but it may take several days to propagate, so please expect this issue to be resolved by approximately mid-next-week.

Thank you! :+1:

Hey @eve, still no change after 6 days. Do I need to give it even more time?

Any word on this, @eve? Still no change, and this unresolved issue is set to “automatically close in 7 hours”.

Should I open a new bug report and/or forum topic?

@shot Reported to our engineering team again. There is currently some code for this that needs to be reviewed before it goes live which should finalize a fix and, unless it needs major rewriting, should be ready for release before EOD today.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.