Error: Azure Text to Speech (REST API) - Status code 403 No permission to access this outbound connection

Hi, I am trying to connect with Azure text to speech api through bubbple api connector. I am getting the following error when trying to initialize the call -

"There was an issue setting up your call.

Raw response for the API
Status code 403
No permission to access this outbound connection."

But I can successfully call the API using same configuration in Postman.

I can’t figure out the issue here. Can anyone help please?

Screenshot of both Bubble and Postman configurations are attached.


in azure you need to put bubbles ip your app is accessing to your allowed list of ips

1 Like

@doug.burden thank your very much for your reply. If possible will you please suggest the way to do that (I mean where to get the ip and put that ip in azure). I am not familiar with this. Or any helpful resources for this will be appreciated.

Have you tried changing the data type from XML to something like file?

1 Like

@rossliddell thank you for your suggestion. I tried that too. Same Response.

Try to debug using a requestbin. Send the request to requestbin from postman and do the same from bubble. Compare both call to find what could create this issue.

Take time to also inspect the auth part of each call

1 Like

Also, remove host and content length. You cannot evaluate this and this should be set by Bubble

Assuming you’ve setup your Azure account and have a valid resource you would just click “set server firewall” on the resource and add the IPs you need.

1 Like

Hi @Jici thank you very much for this. I will check.

@doug.burden thank you very much. I have the azure account and valid resource set up for the the service. I will check.

Hi, @doug.burden I could not find the option “Set server firewall” in my resource group. It might be changed to something or I just couldn’t find it. I am still trying to get it. I will confirm again later.

@Jici I sent the request from both Bubble and Postman. Here are the responses. But don’t understand if there is anything wrong. Both call returned successful (true). Can you please help?

Your screnshot doesnt make sense. Your call are POST but in requestbin they are get. You just need to replace the url in postman and Bubble by the one from requestbin and send the request like you do it to tts endpoint

Hi, @Jici thank you for the correction. I corrected and try again. In postman it was a success (Code: 200 ok). But in Bubble I got the following error. Since I am not a developer I am not quite familiar with everything in API. I am still learning. Your help is really valuable to me and for others like me.


Since the “Host” is ‘Not’ required as header in API call as per the azure documentation. I also tried without it. Then the error shows the following error.

I can see in Requestbin the call from the Bubble is a success though.

requestbin response is JSON and actually your call is set to XML (top right). But for testing with requestbin, it’s not a problem for this error.

Now if you check in your requestbin first POST (from postman) vs last call, you can see that
a) no body was sent
b) no ocp-apim-subscription-key
Can you share your actual settings? Including auth part in API Connector

Hi @Jici sorry for the late reply. I was unavailable. Thank you for your reply. Here are the screenshots.
Bubble -


Postman -

Requestbin (Bubble) - no body was sent

Requestbin (Postman) - body was sent and postman token was sent