Error Operation Timed Out - App too busy

Hi!

Yesterday my users started to see the following error: Operation timed Out

My app makes 4 calls to open ai chat gpt. It normally takes 2-3 minutes to obtain the complete answer of all the calls but now it takes above 5min and ends with the error showcased in the picture above.

I started looking at the server logs and found this:

1)Before it starts to run it passes through a conditional that is this one that works fine.

2)Afterwards it makes the first call to Chatgpt that initiates and finishes without problems


3)On the second call in this example, in between the initialization of the call and the end of it the conditional workflow starts all over again.(The conditional we saw on step 1).


Start of second call. OK.

I think this maybe the problem. It starts the workflow again.This already happened in step one.

Then it finishes the second call.

4)With the third call to chat gpt the same thing happens. In between it starts the conditional workflow again in between the beginning and the end of the call.

  1. It passes too much time and i get one of these errors:

I would really appreciate the help please. My active users can’t use this functionality now and it’s the most used!

Looks like it’s timing out. To confirm this, change all of the calls to gpt-3.5-turbo. If it fixes the issue, then timeout is the problem. Instead of chaining calls in the same API workflow, have multiple API workflows.

API workflows time out (after 5 minutes, I think). If you have three calls that each take 2 minutes, the total is 6 and the workflow will timeout. However, you can have 1 call of two minutes, then schedule a new workflow with another call of 2 minutes etc.

App too busy would indicate maxed out capacity

I noticed capacity gets maxed out way too easily these days…

Hi George,

Im already using GPT 3-5 Turbo :sleepy: :sleepy:.
I tried and separated each API call on one workflow each as seen in the image(The red circled ones)

One worked fine and showed results but on the other two a new problem appeared:
Could not connect to remote server.

I thought it was maybe the api connector but in the other modules of my app i use the same api and it works fine.

Thanks in advanced!

I’ve seen this when it times out.

But its only one call. I was using all 4 calls together and didnt have this issue until yesterday :sleepy:.

Do you have any ideas i could try?

This topic was automatically closed after 70 days. New replies are no longer allowed.