Forum Academy Marketplace Showcase Pricing Features

Error with OAuth 2.0 Login with Google

Hi. I’m trying to add OAuth 2.0 Login with Google to my Bubble site. Login works great, after that, logging out also works great, but after THAT, login gives this error:
Error 400: invalid_request
Invalid redirect_uri contains reserved response param scope
Seems the problem is that after the first login, and than loging out, the URL changes. Google adds &scope=email%20profile%20https%.... at the end of my URL. Because of this the site does not exactly match the settings I have in “Authorized redirect URIs”. At least thats what I THINK is going on. Any ideas?

Thanks! :+1:

What’s your redirect Uri look like?

Like this:

The blurred portion is my domain name.


Did this issue resolve, I currently face the same problem.

I found a workaround

When your user logs out, you can create a workflow action that redirects you to a given page
This way, the url is reset

Navigation > Go to page …

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.