Forum Academy Marketplace Showcase Pricing Features

Facebook OAuth Sign in not getting Access Token via API Connector

Hello!

I’m trying to use API Connector to go set up the OAuth user-agent flow with Facebook. Thanks to the help of the bubble forum I’ve gotten my config to the point where users can click a “sign in” button, go through the process of deciding what permissions to give my app, then get successfully redirected to my app as a signed in user, but my app doesn’t seem to grab the Access Token that should be coming back from Facebook.

As noted in the API Connector UI, I’ve tried going through this process with ?debug_mode=true in my URL, but I’m still seeing the “Warning” that gets display in the API Connector UI, and I’m not able to successfully initialize other API calls via the API Connector UI.

My API Connector settings are below. Any help would be much appreciated!

What do you got when you are in version-test/?debug_mode=true?
You should see a popup that tell you that the API is not initialized and you can add call.

Hi @Jici! Thanks for the reply.

Unfortunately I haven’t seen the popup you’re referring to, but I have been able to successfully create users through the flow. Here are some screenshots to show you exactly what I mean.

Here is my app before sign in:

Here is what I see after clicking the “Sign up or Login button” on the last screen:

Here is what I see after clicking the “Continue…” button within FB (no popup as you can see, but the user is signed in):

Close the preview page, open a new one using “preview” button and not a user. If you don’t get the popup, this mean that the token didn’t get assigned to the “builder” and just to the user. Also, just add it to an empty page (one button with login to a social network workflow)

I just tried this but unfortunately it didn’t seem to solve the issue :confused:

Same here (image below) – this didn’t seem to resolve the issue.

Any chance you have another idea of how I might get the token assigned to the builder? Very helpful distinction to keep in mind – I certainly wasn’t aware of that difference.

I say to the “builder” but it’s just a manner to talk. Because if you don’T use the ?debug_mode=true, you will not be able to initialize call in API Connector. So this is stored differently for this purpose.

The last thing I can suggest you to try is:
Close everything, disconnect from bubble account and clear cache and retry.

Finally, ask for support to have a look at this issue.

1 Like

Thanks for the help, @Jici. I just tried the same workflow using a different browser and had the same issue, so I don’t think it’s a cacheing issue. I’ll send a note to support.

1 Like

Did you try not using the generic redirect url? (Using the same url that the page you have the login?)

I’ve tried unchecking the checkbox next to Use a generic redirect URL in the API Connector config interface, but that unfortunately didn’t fix the issue.

Have you managed to solve this issue? I have the same challenge trying to get the token from the URL from Auth0