Fuzzy search woes || Bubble's plugin platform

I ran into an issue today where the fuzzy search plugin – all of them, I tried them all – crash when I try to ‘unfold’ a data source.

Meaning, this works (video explaining below)

do a search for Leads

However this does not:

do a search for Purchases: each item's Leads

Nor this:

reusable's prop's Leads

Given that the code for all fuzzy searches are descendants from the same parent, there’s a chance that the same problem has been copied over and over.

There’s also a chance that it’s sheer skill issue on my part.

There’s a chance that there’s something wrong with Bubble’s plugin platform? :person_shrugging:

[insert Spiderman pointing fingers meme]

@ZeroqodeSupport , I was going to find the appropriate channels to share this Loom with you but since it might be useful for the community I’ll post it here:

1 Like

Hi @rico.trevisan, :wave:

Thank you for reaching out. The Fuzzy Search plugin is designed to facilitate straightforward searches through your database. While it performs well with direct queries like “Do a search for Leads,” it seems you’re encountering issues with more complex queries, such as unfolding or cross-searching related data.

We recommend sticking to the “Do a search for” method as it directly accesses the desired results, providing a more reliable outcome. If you require functionality beyond this, it might involve complex data manipulations that could be beyond the scope of the current plugin design.

Best regards,
Zeroqode Support Team.