Geographic Addresses not working?

Hi all! It’s only me, or the “Search Box” with Geographic Places (as “Choice style”) are not going correctly lately?

Yesterday everything was working good with my filters, but today the filters don’t work when I write some location on them (e.g. “London” only show a few results when writing “lo”), trying to find the users with the field “Location” in London (for this example) or any other option. Also, if I try to update the Location of one of my users or things (doing Location = SearchBox Location’s value), it takes a long time to save the changes until it gives this error (and the changes are not made):

I have to say that I’m using the field Location as a “geographic address” type, and users just set their Location when updating their profile (after trying other combinations, that’s the one that has always worked best to me).

Do you know what can be happening? Because it was working until 12 hours ago… :frowning:

Thanks a lot!

Hello, Same problem here, as my app is based on that to register customer, well it does not work

1 Like

Appears to be working ok now ?

Google places API is rate limited, so I wonder if we had hit that temporailly?

1 Like

Indeed, it works for me now, finally :slight_smile: It would be great to know the reason to learn how to proceed if it happens again. Thanks!

Pardon the distraction but what is meant by “rate limited”? How was that reflected in this situation?

1 Like

I had the same problem twice today. Here is the solution -

In your app editor, go to Settings > General and scroll to the API section that has two lines about Google Maps. Click on both doc links, hit the blue get a key button and follow the prompts to getting a key. Paste in your keys. It’s free up to 25,000 requests per 24hr period. It should solve it immediately because now you’ll be using your own 25,000 requests instead of sharing them amongst all Bubble users.


As above, if you don’t add in your own API key, then you will be using a shared service.

It is therefore possible that if someone else is hammering Google location search, it might time everyone else out. I Probably didn’t mean “Google Places”.


Thank you!

Something to add. Address autocomplete had worked occasionally for me on an iPad and on a laptop, but NEVER worked on my phone. I tried to find a solution to this a long time ago, but no-one else seemed to be having a similar problem. Perhaps this was a problem unique to me, since I need to use a VPN when testing any google services.

Anyway, adding my own google maps API keys seems to have resolved this issue for me.

1 Like

Looks like that has solved my problems as well, at least for now :slight_smile: THANKS A LOT, @joemanier!

This topic was automatically closed after 70 days. New replies are no longer allowed.