GMAIL API Login error code 400 redirect uri mismatch

Currently Im having a difficult time deciphering between the credentials for each API since they’re all on the same page for each API that is run by google. However regardless of which combination I try, I still get:

Im admitting defeat. Ive read and reread the manual, the entire reference, and taken all the interactive lessons multiple times- and then over again. I’m really good at understanding stuff like this normally. And the thing is, I feel like I do actually know what I’m doing (for the most part at least). But I keep getting stuck on these APIs. Specifically Facebook’s and Google’s (which include’s Youtube’s bc they own each other). I found a great thread for the Facebook issue, but still couldn’t solve my issue. I decided to screen shot my issues and wait for a response, then attempt to fix my Google related ones (Gmail, Google Calendar, and YouTube) in the mean time. Only however, this lead to spending the whole day getting error after error regardless of the changes I tried to implement.
Is there someone out there, that wants to let me pay them to ask questions/coach me into better understanding these APIs? While the documentation on bubble is indeed helpful, it’s just not explanatory enough in some important areas. Or if anyone wants to create interactive lessons or just some basic video tutorials with each of the major APIs (but include the bit about fetching the keys and how some are different and how to accommodate for that) I’d be happy to pay to watch them. Im not looking for handouts, or a mr fix-it. I want to learn. I guess Im looking for a tutor haha- anything to keep me from throwing my computer and along with myself out of the window.
If anyone reading this is like me, some of the really insightful videos Ive seen on YouTube were:

-this one’s super basic but still was decent info:

My email is [email protected] if you want to take it offline.

Hi @alijones, APIs can be tough to sort out because every service has its own requirements, but if you work with enough of them, you’ll find some common threads.

For the Google issue, you’ll want to check the API key’s settings. There’s a section for “Authorized Redirect URLs” - you should enter the exact URL of the page that triggers the Google signup/login in your app.


You have an alternative URL to use, too, instead of specific pages. Go to the plugin settings of the Google plugin and you’ll see an option to use a generic URL. If you check that box, then that’s the URL that will be passed to Google, so you’ll want to enter that into the console settings.


Hopefully this helps you move forward. If you’re interested in a more structured crash course in API stuff, I have a course that covers all the essentials as they relate to Bubble. You can check that out here.


Gaby at Coaching No Code Apps (formerly Coaching Bubble)

Courses & Products, Tutorials, Private Coaching, and High-level Development

Start Learning Today :mortar_board:


Thank you so much! Yes I managed to make sure I tried both of those. I even played around with having “version-test?” present and not present in it. Still get the same code regardless. Alas, I had some folks reach out that Ill be chatting with tomorrow. Ill update with screen shots of my progress in case anyone else is in the same rut!

One of the gotchas with this is that you need to signup with debug_mode=yes to initialise the Bubble side. So you may need to add that into your list of authorised uris.

Also, check the http vs https in there too.

So here is a google one of mine that is working in dev.


But that won’t work if I take off the debug part.


As I said on the other (long) post - it is really really pedantic. It needs to match exactly.

So I end up having two sets per app…


(I just happen to have two apps that use the same service).

Not that these are TEST apps, so never go live.

If I wanted to make them live, I would need to remove the version-test part as well.


Understood. I added it in, but still nada.
I think it might have something to do with my scopes or verifying my domain at this point… however it’s still doing the same thing for facebook as well still Idk. Ill update after I’ve had someone look at it for me.

hey @alijones! I’m working through the same problem. Did you find a solution?

My 2 cents… Triple check yourself for identical authorized redirect URIs. Copy - paste to make sure. Perhaps spaces at the end… Just covering the obvious. Like @NigelG pointed out.

Can you share a screenshot?

1 Like

Thanks for your response! That was actually it- I copied and pasted all url’s I was working with. I knew to do this, but what I hadn’t done was properly add in the Domain, then the URLs. Super simple mistake.

1 Like


Yea that was my first check, but no. I ended learning how to do the custom api input and figured my own way around it without using the plugin.