Having problems with POST method - API Connector

Hello, I was trying to build an simple CMS system using bubble as my front end and Google Apps Script as my backend but it seems there’s a bug with the Bubble API Connector that is not allowing me to make it work. I can’t make the POST method work properly for me (GET is working fine), even though my Apps Script code is right (I’ve tested it with postman).

First what’s working:
As you can see in the next photos the GET method is working as expected (my code simply returns a mockup json).

What’s no working
I tried many variatations of the POST call but they all end up giving me the following error:

This is my api call on bubble:
(I tried using different headers such as Content-Type: application/json and all but it made no diference)

Just to make sure that the problem was not with my code I copied and pasted the same function on both GET and POST. For those familiar with Google Apps Script, here’s my code:

And here’s the same call working just fine with Postman: (as I said I tried using and not using some headers but it didn’t make much diference).

Can anyone help me with this? Is there something I should be doing differently?




Can you share that link of the request, please?

did you solve it? im trying to do exactly what your doing, a post call to an app script, Im getting the same problem, and its working fine in postman.

Im also doing a get call (to app script as well) and that one works fine in bubble… I was thinking of just renaming the function to doGet in app script… maybe it has something to do with how bubble manages the call…

to anybody having the same issue, I solved it by renaming the app script function to doGet, it seems app script interprets all bubble calls as GET…

I haven’t tried to do it since. I was just testing and after I couldn’t make it work went on to work on something else.

Glad you made it work with doGet, but ypur probably not gonna be able to use a body in your request beacause of it.

If you run up to similar problems maybe you can try something like: https://sheetson.com/ I have never tested it but it could solve your problem.