HELP - Button click - API response not showing in a field

I’m not being able to show the response of an API call in a text field.


This is the frontend where clicking the button ‘Get POD’ should is supposed to hit the API we’ve added and show its response in the ‘Group’ or one of the 2 fields:


  1. Here’s the workflow where on clicking the button, the field in the API response which I’ve selected is getting stuck at the next stage of which option to choose to show the data.

While testing, on ‘Inspecting’ the Chrome tab, the API response can be seen post clicking the Get POD button, but the API response isn’t showing in the field I need.

How do I solve this? Thanks much!

Which data type did you set on the Group API Call?

Thanks much @Jici

The fields and button on top is the eventual use case. Currently, there’s no data being sent, I only want clicking the button to show its response inside the field below, i.e. static base 64 data of a file which the API call is returning.

Once this works, will figure the API field data to come from the entered fields on the front end.

Hi. Please pay attention to the wording you use. According to the screenshot. You are trying to send the API Call result into a Group (Group API Call). This group Data Type need to be of the same type that the API call type result too.

Most of the time, we use “Field” to talk about Database (thing) fields. On front end we will talk about button, input, element, group, workflow… So the display data action in workflow your are using is correct to set data source of the Group. You just need to be sure that the Data Source match the expected Data type of the group.

Thanks again @Jici

To not mix up the language, attaching the three screenshots to explain:

  1. Screenshot 1 - Design
    Where I’ve only kept ‘Get POD’ button and a ‘Group’. The ‘Type of Content’ is an ‘API Call’ and the ‘Data Source’ is the API which I’ve added.

  2. Screenshot 2 - Workflow:
    When button is clicked, display data in the ‘Element’ - ‘Group API Call’ (the only other option I had was ‘Index’) - and the fields returned in our API show up in ‘Data to display’.

  3. Screenshot 3
    On selecting the field from the API response to display, this second list shows in the dropdown. I’m stuck here and have tried every combination but none of them allow me to progress beyond.

Screenshot 1:

Screenshot 2:

Screenshot 3:

Can send a video if this isn’t explaining what’s happening.
Thanks @Jici!

The Data to display should stop at "Fedex POD - Api call to match the Type of content of the group.
After that, if you add, for example, a text element, you will be able to select Parent Fedex POD Api call’s soap ENV… (all data from the API call).

But you already have the Data source set in the group element. So you can just add element inside the group and use Parent group data source.

If you want that to trigger only on the press of Get POD, just remove the Data source (leave it empty) in the Group API Call and use the Flow Display data Group API Call and set data source to Fedex POD - API Call

Hi @Jici
Tried both methods but it’s failing at the dropdown at step 3 above.

One request:
If I want to display ‘Hello world’ on clicking the ‘Get POD’ button, how do I do that?

I’ll decode one at a time post that. Showing anything on a page basis a button click is where I’m currently stuck, once solved, I’ll try to decode the rest.

Thanks again @Jici!

Your Group API Call (screenshot 1) Is already configured correctly.
You can copy paste the Data Source to the Data to display (Screenshot 3). This is the same.

Add a text element, and USer Parent group to select what you want to display from the API call
A group itself will store a “thing” (data type). But you need to use an element to display data related to this thing like input, text, image…

Where the “Hello World” come from?