Forum Academy Marketplace Showcase Pricing Features

Help please error header

the error is right in front of me I know! but I can’t solve it, I’ve already looked at the api documentation and I believe I’m doing it correctly, but even so when I make a GET call I always have this error. the attached images are of the error and the fields that contain

unfortunately I don’t know what’s missing! I’ve added more header and nothing. in postman just the url of the call is enough. please help me with some suggestions

Can you provide API doc url?
Also, you can make the call from postman to requestbin. Check all headers and setting there and set the same thing in Bubble.
What I suspect you are missing is probably User-agent

it looks exactly like postman, I just copied the headers that postman showed me. although just by entering the URL in the browser I already have the answer!

What do you mean by requestbin?

http://IP:port/emby/Sessions?api_key=keyapi

some help?

https://requestbin.com/ Send the request to a requestbin endpoint to check what Postman do.

I will test my URL in requestbin. I used my URL in postman for windowsI will test my URL in requestbin. I used my URL in postman for windows And the answer was good, what do you want me to see in requestbin, I can see in postman for windows ?

Inspect all the header in request bin. Set the same thing in Bubble. And use the same requestbin again but from Bubble. Compare both. You may find difference that will explain why it’s not working.

Also, I suggest you to set user-agent header. Did you try? Normally, you should see that header in Postman (and requestbin) too. But it was not set in your screenshot

Sorry for my lack of knowledge, this is all a new adventure. I have some basic api bases. Could you instruct me how to fill this user-agent correctly? How should I fill in the header field? I can even doHow should I fill in the header field? I can even do But if it goes wrong I’ll be wondering if I was the one who didn’t do it!?

you set a header to user-agent and the value to what you want. I can recommend to use Bubble.io/yourappname

The full correct syntax should be
User-Agent: <product> / <product-version> <comment>

looks like I got a different answer! using postman I visualized that the call is only completed when the (Host) is checked. which host should i put? the host syntax is this Host: :
where do I find?

normally, host will have the domain url of your app.
Like www.yourappname.com
if you are on bubble domain, it will be www.yourappname.bubbleapps.io
possible also that you don’t have the www part

I’m still on the trial version, does http://www.yourappname.bubbleapps.io/version-test work?

You don’t need to include /version-test and normally without www.
yourappname.bubbleapps.io

it seems like it’s harder than I thought.
agr i get a 400 bad request code

I found out! key: Accept-Encoding value: gzip, deflate, br
I got an answer can you check if everything is correct for you with the call? follow the print
I get this error body, is this normal?


What type of content do you expect from API?
Seem to be a file. If the type is set to file, it should work

believed it was json. this body in postman returns me the json structure where I can choose which data to display

Can you share the actual setting in both Bubble API Connector and Postman?

of course need everything?