How to Generate User-Specific Data

Hi there. I’m wondering what I need to do, so that the data that a user entered, will be visible only to him. And not the public. I read the documentation on privacy, temporary users, etc. But I’m afraid I didn’t “get it” yet :-(. Who can shed some light on this?

There’s different ways to display only the user’s data.

One way is to create a page and make the “Type of content” for the page “User”.

Then, for any objects you add, give them a dynamic value. For example, here’s how to display a value in the User data type, and since it’s “Current User” it will only show the value for the logged in user.


One additional item you’ll what to add to the page is a redirect, so if a user isn’t logged in, they are redirected to another page, like the Login page, and this you have to add on the Workflow tab.


Hi Kfawcett,

many thanks for your help! I had no idea I could make a page user specific. I tried changing that, but it didn’t quite work for what I am attempting to do. Let me elaborate:

I want to create a page where a user can enter data as a current user (without having an account), which is then displayed. This data should be available only for the current session, unless he creates an account via a button on that page. BTW: I created a field “thing_owner = current_user”.

But the data he entered here should remain visible only to him while the session lasts. Should he close the browser, delete his cookies or whatever, the data should be permanently deleted.

I tried accomplishing as much and created a user-specific page. The fields that I display via repeating group also have the condition to only dislay, if the current_user = thing_owner. Unfortunately, everybody can see everything. I’m kind of lost here.

Update: In my repeating group I now list the created things and added the constraint thing_owner = current_user. All other restrictions regarding the user were removed. Now everytime I add a thing, it appears in the repeating group for about one second, before it just disappears. What is going on? :thinking:

Update2: Eureka! I solved it. I had forgotten that I had been messing around with the privacy settings. That was, what was messing things up.

1 Like

Please mark this as resolved if your issue is corrected.