How to stop session expiration after a day?

Users are logged out 24 hours after their last login, how can I prevent this?

I am pretty sure it is set to 1 day max as that is the standard max duration for token expiry. I suppose you could initially run the ‘stay logged in’ workflow and also add ‘if user has not been active for x days, log the user out’ somewhere in the app workflow. This would need some further testing to make sure it works as intended and doesn’t create any app vulnerabilities.

Thanks for your reply.
The idea that I have it as a mobile app, and the user shouldn’t be logged out even for 7 days for example.
I enabled ‘stay logged in’ but the session expires after 1 day.

Is there any way to extend the ‘1 day’ session?

Hmm sounds like somethings not working, as the session should not expire if stay logged in is ticked.

on the log user in workflow, is the stay logged in workflow setup correctly? it should say ‘checkbox abc is checked’ and remember email = ‘yes’

Hey folks!

Our team is performing some updates to the stay-logged-in feature at the moment to correct this behavior; we expect this to be resolved before the end of this week. If you’re still having trouble by Monday, please do file a bug report!


Hi Eve, do you know if this got fixed and was deployed? We are having the same issue. Stay logged in is checked at login / account creation, yet the user is logged out after ~1 day

Actually, quick question @eve: does the “stay logged in” feature only work when there’s a checkbox checked for “stay logged in”?

Preferably we can default to having the user remain logged in always, but if the only way to do that in Bubble is with the checkbox, we can add that.