Forum Academy Marketplace Showcase Pricing Features

I want the audio player to automatically play when page is loaded

Hi,

I am using plugin “Audio Player BEP”.

I would like that when the app page is loaded, the player automatically starts playing.

I did an event : when page is loaded → play audio player

However it doesn’t work.

Here is a screenshot of what I captured as error.
Does someone know how it can be resolved ?

Note : it worked a while ago but I don’t remember how I did it.

Up ? :pray:

What data are you sending to the audio player? Are you able to play it manually, or is just the autoplay failing to work? It seems from the error message like the data the audio player is being asked to process something it cannot process.

Data is some audio files .mp3

The play button of my player works good. It’s only the autoplay that doesn’t launch when page is loaded.

Is there a “start playing” action for your plugin? You can do a When condition is true workflow with the condition Page is loaded (entire) to trigger the audio player.

Or maybe the plain old Page is loaded workflow would do it

Doesn’t it work to select the “Auto Play” option?

I did a workflow like this yes (cf screenshot here and in original post) but it doesn’t work.

Also strange thing is that when I upload page in “normal run”, the bug appears.
If I upload the page in “next step” of debugger, the bug won’t appear.
So I guess maybe it’s due to some timing or something ?

It is currently in autoplay mode

image

I think this could be the reason yes. I tested on Chrome : didn’t work. I tested on Firefox : worked (after I authorized autoplay in browser configuration)

try this: create a custom workflow when you put the "Play audio x step, and when the page is loaded, try a “Schedule custom workflow”, then try 0 seconds at first, then 1 second, and 5 seconds… try longer till it gets right

Like this ?

Custom event :

Trigger Play:

almost… Put the step “Play audio timeline” inside the custom workflow

Ok I did it.

Still doesn’t work though. It’s weird because when I run the page load normally, the bug appears. But if I run the page load step by step with debugger, it then works out.

https://bitzz.bubbleapps.io/version-test/index/Lorem%20ipsum…?debug_mode=true