Ignore Privacy Rules Backend Is Ignored?

What is correct here? I am confused.

The manual states

My Backend workflow is set up as so

Screen Shot 2020-07-13 at 6.37.07 PM

Running in step by step mode I see this

Seems like checking the ignore privacy rules is telling the system to not ignore the privacy rules since reading the step by step mode “ignore privacy rules when running the - no” would indicate that ‘no’ means ‘no do not ignore the privacy rules’

Set up like this

Screen Shot 2020-07-13 at 6.39.57 PM

Without checking the ignore privacy rules box, I see this in step by step mode

Again it reads as ‘no’

So what is the deal here? An issue with the step by step mode? A bug? Why would the ‘ignore privacy rules when running the’ not change no matter if I have the box checked or not?

Part of my frustration with this right now, is that no matter what I do this backend workflow is not running and creating the data elements I need it to create — Very frustrating.

@eve should the ‘ignore privacy rules when running the’ change between a yes and no value dependent on whether the ‘ignore privacy rules box’ is checked or not checked in the backend workflow?

Reviving this topic, not sure if you ever got an answer to this @boston85719 but I’m running into the same issue.

I’m trying to run a backend workflow that sends an email, the email address is hidden by privacy rules. Setting both the schedule api workflow, and the api workflow itself to ignore privacy rules does nothing, and therefore the email is not sent.

I can confirm that the issue here is the privacy rule, since turning off privacy for email passes the email address to the backend workflow, and the email is sent.

@eve are we missing something here, the documentation seems rather clear, it should overrule any privacy rules set on the data being sent to the backend workflow, right?

1 Like

Never got a response. Ignore privacy rules works for me now. You may want to submit a bug report.

Thanks @boston85719. Interesting, did it just randomly start working on its own or you changed your set up?

I don’t recall on the situation from the thread but generally no issues.

No matter what I try it doesn’t work. I’ll submit a ticket if I can muster the patience later on. For now I’ll just pass the email as a url parameter, probably better then overriding privacy and briefly exposing all user’s emails anyway.

1 Like

Reading your post closer my assumption is you are trying to send a value that is hidden, meaning you don’t have access to it for purpose of sending it to backend.

Try sending the entire User to the backend and in your backend reference user email. All you need then is make sure privacy rules allow your user to be found in searches and any data you use in search constraint is accessible.

@casheets123 this just broke for me too! My app runs 90% on chains of backend workflows and this bug is crushing me right now.

My app is completely non-functional and the bug team only works 9-5 now??

Did you every find a solution?

Can you share your settings @aj11 ? We have no problem using this setting.

This is the workflow being scheduled:

This is the workflow itself:

The “Step” Thing has a “Message Content” field on it. Out of the blue today the “Message Content” is now empty even though I can see the data in the database and it will display on the frontend (where privacy rules allow it.). Up until today using this setting there was no issue getting the data from it, but now it is empty.

I added a “Send email step” to the workflow and sent all the different fields of “Step”. The only field that is accessible is the unique id field. So I know a step is being sent, the workflow just isn’t able to access the data on it despite the fact that “ignore privacy rules” is selected.

1 Like

I didn’T know it was working before. There’s a release today related to signup flow in backend . That might be the issue. You should send a support ticket.
We will check on our side too if we have issue.

Yeah I submitted a report so I guess I’ll hear back in the morning. It’s inconsistent too though, I was just able to get the workflows to run when triggered by one part of my app, but not when triggered by the other. Very strange.


I believe I found a way to stop the behavior in my app. At least my tests are all working now.

Here is the setup that wasn’t working:

Workflow 1 is scheduled on frontend:
param2 (thing1)
param2 (thing2)

Workflow1 schedules Workflow 2.
param1 (thing1)
param2 (thing1’s things2[which = thing2])

Thing2 from param2 in workflow 2 had it’s field incorrectly hidden. This is the bug.

I solved this by just subbing thing1’s thing2, for just the thing2 that was being originally passed. Once I did this it worked.

So all of this is to say. It seems there is a bug whenever you want to use fields from a thing’s thing when chaining api workflows together.


Dear all,

With the help of @Jici i can confirm that i have the same bug. Setting “Ignore privacy rules” is not working on by backend workflow.

Post here : Help ! Stuck on sending files (privacy rules) - #7 by d.pimentel

However in my case the setup is different : i have 3 parameters and only 1 backend workflow.

The problem of privacy only apply on files


Edit: i find the problem

The Ignore privacy rules should be used in the backend AND frontend action, otherwise the option not apply

What I found worked was recreating the privacy rules and some some of the workflows. This occurred for me after changing the name and domain of our app and I think some of the privacy rules were broken somehow. Recreating them got everything working again.

Actually it’s still not working for me…!

Try rebuilding as much as possible of your workflows and privacy rules and see if that helps. Don’t copy paste anything as that could drag the problem with it.