Issue with Signup using Google

Hi,
Can anyone please help me out with Google sign up issue.
Here is the issue I am facing.

I understand by seeing this error I need to place the url in redirect URIs list . Actually I have a signup using google button(In signup popup) where the user can sign up when click on that button. I have this Button in all the pages so that user can sign up in any page.

I have placed all the Page links in Authorized redirect URIs list (which is in Google console).
Here is the screenshot.

So I have a dynamic page(named as Sub-category) where there is also signup google button. I also need to place this page URL in that list so that google allows the access to the user to get signed up.
But as this is a dynamic page and the URL always changes How should I place the URL in this Redirect URI list …

Please help me out with this issue.

thanks

Looks like your first screen shot uses /category/Australia but google console has /sub-category/Australia and those uri’s need to match exactly. You also might want to look at the recently added option of Use a generic redirect URL, which allows you to use a single entry in google console for multiple pages.

–Ken

Thanks for your reply @mebeingken

Actually i have “Australia” category in both category and sub-category page where both these pages are dynamic.

How could we use single entry for multiple pages ? Could you please explain briefly ?

Thanks.

The value in google console needs to match exactly, the uri of the page making the request. In your 400 error from google, it is:

https://quizkangaroo.com/version-test/category/Australia

but in google the closest thing you have is:

https://quizkangaroo.com/version-test/sub-category/Australia

If you change nothing else, just change google console to have the first one included.

The other option is to use the new feature on the API Connector, which allows you to have all requests coming from a static uri. You add that single entry into google console, check the tick box on the API connector next to “Use a generic redirect URL”, and away you go. The url used in google console, will be listed next to the tick box in API connector.

–Ken

Yessssss…

I have checked the tick box called “Use a generic redirect URL”.

And placed only one single URI in google console as “https://mysite.com/api/1.1/oauth_redirect

And it works perfectly now.

Thank you so much @mebeingken