Lost my workflow

Hello there,

While building my first app, I sometimes realized things I just did disappear. I feel I maybe clicked on cancel/redo button without realizing but it’s apparently something different. Today I lost my workflows for a specific page when loading bubble for the first time of the day, so I tried to restore to a previous point in time but when I do so, I lose my index page that becomes empty.

Is this a common known problem, that we can easily lose parts of our app ?

That used to happen to me when I would do the shortcuts to undo on the keyboard (Command-Z). I try to avoid using the keyboard to undo anything. Just use the button at the top of the screen. There are multiple clipboards that Bubble uses to copy things so sometimes you may try to undo something and not realizing it you would undo things on another page or something that you aren’t looking at currently.

Sometimes I used to keep trying to undo something by pressing undo on the keyboard multiple times, nothing changing on my screen. I thought it didn’t do anything but it really did, I just didn’t realize it.

I hope that helps. Not sure if it was the same thing that happened to you or not. Sorry for you losing work. I know that’s frustrating. :confused:

Thanks @J805, after your explanation, I was able to restore an old version with the index page, did a copy to the clipboard, then restored the latest version that had my previous workflow and pasted my index there :sweat_smile: . I’m happy I didn’t had to do it all over again! Now I’m more careful with keyboard shortcuts.

I, too, think that this undo button is not verbose enough, and I think typing delete on keyboard will also delete selected workflows even if you are not on a workflow view.


Glad that helped! It used to drive me crazy not knowing what happened to things. Happy it worked out for you. :clap:

Want to learn more?


1 Like