I lost all work

Hi, I was working on Bubble when it crashed.

When it came back I noticed that I lost everything I had created in the Index, everything was empty, I tried to go back several times but it didn’t work.

I spent 15 days of work, I can’t lose!

Can I get back everything I did?

Are you sure you’re on the right version or app?

I’ve never seen or heard of this before.

Only thing I’ve seen is losing internet connection & losing a few minutes of work if auto saving doesn’t get pushed through.


hmm :thinking: That a tricky one.

Were you not online and connected to the internet for 15 days? That is the only way I think that would happen. Like @chris.williamson1996 said, usually it’s just a few minutes of time that you might lose, but not 15 days.

Things to check:

Are you in the right app?

the right version (live/dev)?

the right page?

Does reverting back help?

Do your app as public instead of private?

Could someone else have accessed the app and deleted everything?

Do you have any collaborators?


100% sure, I only have one application on Bubble, I don’t have another.
Everything really disappeared, even the Workflows were deleted.

Even Worflow disappeared, there was much, much more!

The screenshot cuts off important info, like what version you are in. :man_shrugging:

It seems that there is only a popup on this page (that is currently hidden). What should the page have on it?

Are you sure you are in the right app?

Things to check:

Are you in the right app? Yes, I only have one APP

the right version (live/dev)? Dev

the right page? Yes, is One page system

Does reverting back help? I did not understand your question.

Do your app as public instead of private? Private

Could someone else have accessed the app and deleted everything? No, only I have access.

Do you have any collaborators? No

I went to put an Input on the screen, Bubble crashed, and when it came back, everything came back empty.

I can see some elements in the error part.

What happens when you click on the error?

Did you by chance build everything in a popup? Do you need to display the popup from the element tree on the left side? :man_shrugging:

I didn’t build everything in a popup, I took a ready-made Bubble Template and worked on top of it.

When I click on the error nothing happens, it freezes and returns to the same screen.

I use keyboard shortcuts a lot and more times than I’d like to admit I’ve selected everything with CTRL+A or dragged and accidentally deleted a mass number of items.

Can you try to undo a few times? Or click the blue upgrade to deploy and roll back to a certain time? (Not sure if you can on free apps).


If you have a paid app, you could revert back to a time when you knew it was working right.


How to get to this screen?

You have to have a paid app. Then you choose this:


You’re not on a paid plan (hence the blue Upgrade to deploy button in one of your screenshots), so you won’t be able to roll back. If you did what Chris suggested and tried hitting the undo button a couple of times, then you probably need to contact Bubble at support@bubble.io to see if they can help.

1 Like

I just signed up for the paid plan, but apparently there is no backup prior to signing up.

I got it with a paid plan, set it to a personalized day like yesterday, and Buuble restored everything.

Still, I feel very relieved.


Ah, I was actually wondering if you could enter a custom date/time after you upgraded, but I didn’t know if that would work. Thanks for following up and letting us know… happy to hear you got everything back!