'Make changes to a thing' not occurring every time

Hi there!

I have a workflow set up so that every time a user types a term into my search bar, it stores that term in a list in my database.


Every month a scheduled backend workflow creates a new ‘thing’, so that’s why it is set to ‘last item’.

This works the first time they type something into the search bar. And then it just doesn’t??? Other workflows with the exact same trigger work every single time but for some reason there seems to be an unknown logic that just stops this workflow from working randomly? Sometimes it even does add to the data base after the first entry, but not consistently.

I’ve tried doing this with backend workflows and various other combinations of searching for Unique ID instead of ‘last item’ but to no avail.

Help would be greatly appreciated.

The problem might be with the ... value changed... workflow. It doesn’t trigger as you expect (like after every input change). It waits for the enter button or the input to unfocus. IF this is what you wanted, that’s ok. But I suggest you check around that.

If you truly want to get the input value change workflow (like after every character, you should use 1T - Input Watcher Plugin | Bubble plugin.

Hi thanks heaps for the reply!

I tried this out but the action ‘A Watch Input value changed’ only logs the first letter of each search term into the database, and ‘A Watch Input enter pressed’ doesn’t seem to work at all :cry:

Do you know of any work around? Thanks