Forum Academy Marketplace Showcase Pricing Features

"message":"No application matches the supplied client identifier"

Hello, everyone. I ran into an issue regarding stripe. Long story short, I get this screen on live mode but during development mode it seems to be working OK. The first screenshot is “Live” and the second screenshot is “Development”. I have no clue what is going on. Hopefully, something simple.

Live

Development

I’m seeing the same screenshot for both, but check all your keys in the Stripe plugin settings. They should be different for development vs live. Your Stripe account has a test vs live toggle as well, which will allow you to get the keys for each mode. Seems like you might only have test keys in there right now.


Gaby at Coaching No Code Apps (formerly Coaching Bubble)

Courses & Products, Tutorials, Private Coaching, and High-level Development

Start Learning Today :mortar_board:

1 Like

Thank you for your time. Silly me… there, I fixed it. :joy:

Apparently, I have both test and Live keys

1 Like

I fixed the issue. For anyone facing this problem, my issue was that I was using the wrong Live Client ID. I am having another issue but that’s for another thread.

Hi @teacher.mr.aviles . where did you find the right Live Client ID? I currently have the exact same error as you on the first screenshot and my client ID doesn’t look like the format of yours. Mine is a long encrypted string. Could you point me in the right direction please?

Hello @jamesonvparker. First log into your Stripe account. After that on the left hand side you will see an option that says “Developers”. when you click on developers, you will see an option that says API KEYS. Once you are there, you will have an option for “live API keys” (pk_live_xxxxxxxx) and “Developer API keys” (pk_test_xxxxxxx). Make sure you put each one accordingly.

My client IDs are the same.

I’m sorry, but where can i get my Live Client ID?

Here’s where to find the live client ID and dev client ID:
In the upper right part of the dashboard, click the gear icon and under the Connect menu select Settings.
Scroll down the page and your client ID will be visible. You can also grab a test URL to preview what your customers will see and get the client ID from the URL parameters.
Mine was not working and I somehow managed to paste it in with a space in front of it, so check for that! :slight_smile:

You are a life saver. I have been having the same issue without been able to fix it for weeks lol.
Your comment was the saver. I had a space in front of the Client ID that I wasn’t aware of. Thank you