Forum Academy Marketplace Showcase Pricing Features

[New Feature] Database connector

@emmanuel @georgeciobanu - guys can you please answer this question? it’s for the client
is it possible to use server’s alias instead of an IP address in the connection string? for example like thisaa107oshby1g79j.cf234yrgtj6cf.us-east-1.rds.amazonaws.com

Yes, you can, but we can’t guarantee that won’t change either.

Wcan discuss setting up a fixed IP for someone with dedicated hosting (enterprise plan).

I have a small issue. I connected to a MySQL database on AWS.
So I want to use a field called Reg No as a parameter. When I define the query string as:
select * from All_PL where Reg No=? limit 200 - it gives an error
when trying this
select * from All_PL where Reg_No=? limit 200 - it doesn’t find the field
when trying this
select * from All_PL where “Reg_No”=? limit 200 no error but in the run mode it doesn’t return any results when using this query.
When using a parameter with a field that doesn’t have spaces (for example “model”) everything works fine.
In the forum app shared by George, he uses “where emp_no=?” and in the parameter details it appears “emp no” and seems to work.
But in my case there is an issue with using a field that has a space.
Any suggestions?
Thanks,

Have you find the issue?

Did you try “Reg No” in quotes?

You also might try Reg%20No with no quotes.

FWIW, it’s best to NOT embed spaces in anything. Use underscores instead.

1 Like

Thanks, WIz, we solved it simply be removing the spaces in the field names. I think we tried using quotes and %20, as far as I remember it didn’t help.

Thanks,
Levon.

Founder at Bubblewits - Bubble Certified Partner


http://iambubble.com - one page Bubble demo
http://builtonbubble.com - Collection of apps built on Bubble
Dev.zeroqode.com - Reach out if you need help creating something on Bubble

1 Like

Let us know if the dot (and other special characters) is a recurring issue. if so we can try to do something about it.

1 Like

the problem was with the spaces. We have removed the spaces in the field names in our SQL database, but i guess that it may not be always possible, if the Bubble user doesn’t own the database. So if you could fix the spacing issue in the connector that might be helpful for future cases.

1 Like

Hello @georgeciobanu ,

Could you make an example of how to export the data to Mysql database?

I´ve been reading the forum but yet I can´t figure out how it´s possible.

Thanks a lot.

Hi,

So I’ve got access to a postgres database that is fully-managed by aiven.io (located on Google Cloud Platform in Iowa – which I presume is us-central). I am having trouble connecting it to the DB Connector plugin – please bear with me as this is my first time working with Postgres.

(To cut to the chase, I have a hunch that my database requires connections over SSL but currently bubble does not make SSL postgres connections possible – can you comment on whether SSL connections actually are or can be supported?)

"Test"ing yields an error like: no pg_hba.conf entry for host "<some-ip-address>", user "<my-db-user>", database "<my-db>", SSL off

I can connect to the database without issue using psql --version # psql (PostgreSQL) 9.5.1 in my terminal.

The connection string provided by Aiven is generally postgres://<my-db-user>:<my-db-password>@<alpha-numeric-with-hyphens>.<alpha-numeric-with-hyphens>.aivencloud.com:<my-port>/<my-db>?sslmode=require

I get the same error with and without the ?sslmode=require query in bubble. I can connect in the terminal without the query, but I presume that the CLI just eats the error and uses SSL transparently.

I do not have direct access to the pg_hba.conf file (I’m communicating with Aiven to get a copy of it and evaluate whether or not the SSL requirement can be relaxed – which frankly sounds ill-advised to me…) but the Aiven interface gives the option to set comma-delimited admissible IP ranges (currently set to “all IPs” i.e 0.0.0.0/0) and I presume that is driving the contents of pg_hba.conf.

Any thoughts? Thanks

As a follow up, I’ve confirmed with Aiven that the pg_hba.conf has records in this format:

hostssl <database> <user> 0.0.0.0/0 md5

I’m still trying to get them confirm whether or not having non-SSL records in the config would work in theory, but there infrastructure is not really set up to permit that sort of setup. They also mentioned they were able to integrate their database with blockspring – should that information be relevant/helpful (please don’t recommend that I user blockspring as a proxy…).

Please add Microsoft SQL Server option to database connector.
It’s all that I need to move my apps from apperyio to bubble

2 Likes

Please reach out to [email protected] to talk about this.

Hi George, I am trying to post data from input fields into a new row of a specific table in a postgres database. So far I was able to connect the database, retrieve information from it and even setup a call that would allow me to insert a new row. Here is the querry I had setup for reference:

insert into public.invoice
values ($1, $2, $3, $4)

This call was initialized without a problem.

However I can’t access this query. I assumed I would find it under the workflow tab under actions - plugins. Similar to how to write to Zapier, but the SQL plugin doesn’t even show. How can I write to the database? Thanks

Can you share a link to the editor?

If you set the query to “Use as Action” in the plugin settings, then the workflow actions show the query under Data (Things).

1 Like

Thanks! Setting the query to use as action worked right away!

1 Like

Hello, I am Brazilian, with little fluency in English, so I apologize in advance if it is not clear. I was wondering if the opposite is possible. Example I create a web app on the bubble and I create a mobile app with Xamarin and I want to connect to the Bubble bank, is it possible?

@alanhmartins, yes it is:

https://manual.bubble.io/using-the-bubble-api/how-to-use-the-api

1 Like

Is there any connector for oracle database yet?

1 Like